Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда

10-11 класс

положительных чисел нет

мшлнын 08 апр. 2014 г., 23:20:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tanuxa81
09 апр. 2014 г., 1:21:53 (10 лет назад)

program test;

var n, total, counter, i:integer;
begin
   total:=1;
   counter:=0;
   for i:=1 to 10 do
   begin
      read(n);
      if n < 0 then
         counter:=counter+1
      else if n > 0 then
         total:=total*n;
   end;
   writeln('The number of negative elements = ', counter);
   if total = 1 then
      writeln('Positive numbers no')
   else
      writeln('The product of positive numbers = ', total);
   readln;
end.

Ответить

Другие вопросы из категории

где можно быстро создать сайт?
Написать программу в VBA:

2 февраля вкладчик положил на счет в банке 2000 грн. (PV) под 25% годовых (r) (схема обыкновенный процент и приблизительное число дней). По какое число нужно делать вклад, чтобы получить 3550 грн. (FV)? Длительность года по схеме приблизительное число дней будет 360. t=(FV/PV-1)*T/r; t-число финансовой операции, T-длительность года.
Очень нужно, пожалуйста...

ОПЕРАЦИОННАЯ СИСТЕМА:ПОНЯТИЕ,ВИДЫ.

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу



Вы находитесь на странице вопроса "Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.