Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны три числа a,b,c. Если среди них есть положительные, то найти сумму этих трёх чисел, а иначе найти максимум из трёх.

10-11 класс

Vlad163mak 24 июля 2014 г., 21:49:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Darishka99
25 июля 2014 г., 0:23:51 (9 лет назад)

Program df;
uses crt;
var a,b,c,max,sum:integer;
begin
sum:=0;
max:=0;
writeln('введите  числа а,b,c');
readln(a,b,c);
if (a>0)or(b>0)or(c>0) then sum:=a+b+c else if (a>b)and(a>c) then  max:=a else if (b>c)  then max:=b else max:=c; 
if sum=0 then wrteln('Числа отрицательные большее из них ',max) else writeln('сумма чисел ',sum); end.

+ 0 -
Deniskravchenk
25 июля 2014 г., 1:02:34 (9 лет назад)

Тебе отрезок программы нужен?

+ 0 -
Lizka1998
25 июля 2014 г., 2:21:10 (9 лет назад)

программа нужна вся

+ 0 -
Майер
25 июля 2014 г., 3:14:44 (9 лет назад)

без проблем

+ 0 -
Katyushalove9
25 июля 2014 г., 4:09:36 (9 лет назад)

теперь вся

Ответить

Другие вопросы из категории

Пожалуйста сделайте в Паскале задание лёгкое, но постоянно ошибка:

"Дан массив из 5 чисел, найти количество элементов которые равны минимуму."

Читайте также

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL! ПОЖАЛУЙСТА!

Дан массив X(N,M). Если первый элемент массива положительный, то найти сумму элементов среди элементов четных строк массива, иначе произведение.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если первое число четно, то выведите сумму этих четырех чисел.
Если второе и третье числа положительны,то выведите их среднее арифметическое.
Если выполняются одновременно два перечисленных выше условия, то выведите все четыре числа без изменения.
Иначе, выведите числа, противоположные исходным.
Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Ввести массив F(n) вещественных

чисел. Если последний элемент массива положительный, то найти max среди
элементов массива и заменить его значений последний элемент массива. Массив
распечатать. Иначе – дать сообщение «Массив остался без изменений»



Вы находитесь на странице вопроса "Даны три числа a,b,c. Если среди них есть положительные, то найти сумму этих трёх чисел, а иначе найти максимум из трёх.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.