Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите составить калькулятор в программе Паскаль

5-9 класс

Sauyra01 16 окт. 2016 г., 1:30:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
миленка112
16 окт. 2016 г., 4:13:38 (7 лет назад)

program calc;
var
operation:byte;
a,b:integer;
begin
writeln('a');
readln(a);
writeln('b');
readln(b);
writeln('1 - sum');
writeln('2 - sub');
writeln('3 - div');
writeln('4 - mul');
readln(operation);
case operation of:
1: writeln(a+b);
2: writeln(a-b);
3: writeln(trunc(a/b));
4: writeln(a*b);
end;
end.

Ответить

Другие вопросы из категории

Файл размером 9 Кбайт передаётся через некоторое соединение со скоростью 1536 бит в секунду. Определите размер файла (в байтах), который можно передать

за то же время через другое соединение со скоростью 1024 бит в секунду. В ответе укажите одно число — размер файла в байтах. Единицы измерения писать не нужно.

1. Объясните,пожалйста Световое табло состоит из лампочек, каждая из которых может находиться в 2 состояниях: «включено», «выключено» .Какое

наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передать 64 различных сигнала?

Читайте также

Помогите составить программу по Паскалю, пожалуйста.

Клоун
предложил каждому из публики задумать число. Потом он сказал: «Прибавьте к
задуманному числу 5. Теперь из результата вычтите 2. А теперь к результату
прибавьте 7». Потом клоун спросил у желающих, какое число у каждого из них
получилось. Услышав ответ, он немедленно объявлял каждому, какое число тот
задумывал. Составьте программу, которая повторяла бы фокус клоуна.

Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)



Вы находитесь на странице вопроса "Помогите составить калькулятор в программе Паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.