Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано натуральных чисел n. в каждом числе Переставить цифры так, чтобы образовалось минимальное число, записанное теми же цифрами. Цифра "0" не может

10-11 класс

быть первой в числе

Эн51 23 апр. 2013 г., 11:32:15 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asadtea
23 апр. 2013 г., 13:30:16 (11 лет назад)

var
  n:string;
  t:char;
  i,j,k,s,m:integer;
  a:array[1..1000]of string;
begin
write('Сколько будет чисел: ');
readln(s);
for i:=1 to s do
  begin
  write('Введи число: ');
  readln(a[i]);
  end;
for m:=1 to s do
  begin
  n:=a[m];
  k:=length(n);
  for i:=1 to k do
    for j:=i to k do
      if (ord(n[j])<ord(n[i])) and (not((i=1) and (n[j]='0'))) then
        begin
        t:=n[i];
        n[i]:=n[j];
        n[j]:=t;
        end;
  writeln(n);
  end;
end.

+ 0 -
LizaOwi
23 апр. 2013 г., 14:07:46 (11 лет назад)

постарайся очень нужно

+ 0 -
Vikusyafedorov
23 апр. 2013 г., 16:44:49 (11 лет назад)

динамические массивы можно использовать?

+ 0 -
Samircaazizova
23 апр. 2013 г., 19:43:56 (11 лет назад)

не желательно

+ 0 -
Prizrakstalk
23 апр. 2013 г., 20:17:41 (11 лет назад)

та используй как тебе удобно будет

+ 0 -
Missisalibegova
23 апр. 2013 г., 23:17:30 (11 лет назад)

Проверяй

Ответить

Другие вопросы из категории

Модему, передающему информацию со скоростью 512 байт/c, потребовалось 1 минута и 4 секунды, для того чтобы передать растровое изображение. Укажите

максимальное количество цветов в палитре изображения, если известно, что его размер составил 128x256 пикселей. Ответ записать в виде целого числа

Написать программу в Паскале!!!

Указание: Заполнить двумерный числовой массив И(8,8) случайными целыми числами в интервале [-60,60].Написать единую программу для всех задач,ответ каждой задачи выводить с новой строки.
Задача: Создайте новый одномерный массив из элементов,имеющих значение больше -5.

Срочно нужно решить

1.Написать программу деления 2-х чисел с проверкой деления на ноль.
2.Написать программу,которая выведет возрастающий ряд натуральных чисел от 1 до N.
3.Написать программу,которая в таблице 5*6,заполненной целыми сл. числами из промежутка от -40 до 40,вычислить модуль разности между суммами отрицательных и положительных элементов.

Читайте также

1. Дано натуральное число n. Переставить его цифры так, чтобы образовалось максимальное число, записанное теми же цифрами.

2. Найти все двузначные числа, сумма квадратов которых делится на 17.

Всё это нужно сделать в программе Паскаль, но КАК?!

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.



Вы находитесь на странице вопроса "Дано натуральных чисел n. в каждом числе Переставить цифры так, чтобы образовалось минимальное число, записанное теми же цифрами. Цифра "0" не может", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.