Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

почему программа в pascal ABC выдаёт что массив 0

5-9 класс

program peremena;
const N=8;
var A:array[1..N] of integer;
I,X: integer;
begin
for i:=1 to n do
if i>N then
begin
begin
x:=a[i];
a[i]:=a[n];
a[n]:=x
end;
begin
x:=a[i+1];
a[i+1]:=a[n-1];
a[n-1]:=x
end;
end;
writeLn('массив',A[i]:8)
end.

Nastyaikonina 11 июня 2014 г., 23:53:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alessandrov
12 июня 2014 г., 1:50:49 (9 лет назад)

Смотри вложение
........................

+ 0 -
Марина0215
12 июня 2014 г., 3:56:17 (9 лет назад)

тогда проще вывести элементы массива с конца и вообще не делать перестановку

+ 0 -
Amina20032005
12 июня 2014 г., 4:30:47 (9 лет назад)

нет мне надо с помощью перестоновки

+ 0 -
MiniFick17
12 июня 2014 г., 6:19:22 (9 лет назад)

прежде чем делать перестановки надо массив сформировать, у тебя этот этап отсутствует

+ 0 -
DashaDornyak
12 июня 2014 г., 7:35:55 (9 лет назад)

ну напиши пожалуста

+ 0 -
Knopochkau
12 июня 2014 г., 10:15:20 (9 лет назад)

я в программирование ничего не понимаю

Ответить

Другие вопросы из категории

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили

координаты х и у и программа проверяет, подходит ли эта точка к графику или нет. Пример на 2 фото.
Очень нужно. 80 баллов

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "почему программа в pascal ABC выдаёт что массив 0", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.