Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Сколько чисел нужно взять в последовательности : 1+2+3+4...N. Чтобы получилось число, больше чем N? При N=252 нужно взять 23 числа

5-9 класс

Программа + блок-схема.

Аnyuta 17 авг. 2014 г., 4:38:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pechenushka
17 авг. 2014 г., 5:23:38 (9 лет назад)

Программа №1: 
Var  n,i,sum:integer;
Begin 
  Write('Введите N в последовательности 1+2+3+4...N: '); readln(n);    
     while(sum<n) do begin      
i:=i+1;      
sum:=sum+i;      
             end;  
 Writeln('Чтобы получилось число больше ',n,' нужно взять ',i,' числа');
End.

Блок-схема в приложении

Задача №2 

Var   i:integer;
   a1,a:real;
Begin
a:=65000;
for i:=1993 to 2014 do 
   Begin 
Writeln(i,' год - ',a:0:0,' жителей'); 
a1:=(a/100)*3; 
a:=a+a1; 
     end;
End.

+ 0 -
Planovay
17 авг. 2014 г., 6:48:32 (9 лет назад)

Комментарий удален

+ 0 -
Fart83
17 авг. 2014 г., 9:13:05 (9 лет назад)

Спасибо)
А можно ещё ко второй?)
Пожалуйста

+ 0 -
Loya90
17 авг. 2014 г., 10:02:03 (9 лет назад)

Комментарий удален

+ 0 -
Okurtmina
17 авг. 2014 г., 11:14:03 (9 лет назад)

Комментарий удален

+ 0 -
Verandachka
17 авг. 2014 г., 12:03:12 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!
. Используя набор данных "Крупные водохранилища России" (Приложение, №7), составить таблицу и выяснить суммарную площадь водохранилищ,

средний объем водохранилищ, максимальную глубину и минимальный напор водохранилищ.

1)Что необходимо знать при разработке алгоритма?

2)Перечислите известные вам формы записи алгоритмов?
3)Злая мачеха отправила падчерицу за водой "Вот тебе 2 ведра, в одн из них входит 9 литров воды, а в другое 5 литров. Но ты должна принести домой ровно 3 литра воды",- сказала она бедной девушке.Как должна действовать падчерица, чтобы выполнить это поручение?
4)Какие геометрические фигуры используются в блок-схеме?
5)Каким образом задается порядок выполнения отдельных действий в блок схеме?

Читайте также

Сколько секунд потребуется модему, придававшему сообщение со скоростью 14400 бит/сек чтобы передать растровое изображение размером 800×600 пикселей, при

условие, что в палитре 16 миллионов цветов?Сколько секунд потребуется модему, передающему сообщение со скоростью 14400 бит/сек, чтобы передать цветное растровое изображение размером 800×600 пикселей при условии, что в палитре 16 миллионов цветов?



Вы находитесь на странице вопроса "Сколько чисел нужно взять в последовательности : 1+2+3+4...N. Чтобы получилось число, больше чем N? При N=252 нужно взять 23 числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.