Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

10-11 класс

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Natashasasina 02 мая 2015 г., 7:04:25 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dasha2013ustinova
02 мая 2015 г., 8:26:41 (8 лет назад)

1)

var

  str : string;

begin

  readln (str);

  writeln (length (str) - pos (':', str));

end.

 

2)

var

  str, s : string;

  count, i : integer;

begin

  readln (str);

  s := copy (s, pos ('(', str) + 1, pos (')', str) - pos ('(', str) - 1);

  count := 0;

  for i := 1 to length (s) do

    if s[i] = ' ' then inc (count);

  writeln (count + 1);

end.

 

3)

var

  str : string;

  count : integer;

begin

  readln (str);

  count := 0;

  while pos (',', str) > 0 do

  begin

    inc (count);

    delete (str, pos (',', str), 1);

  end;

  writeln (str);

  writeln (count);

end.

 

Сделано без проверки на соответствие условию.

Ответить

Другие вопросы из категории

2. В каком языке

программирования отсутствуют типы данных?


А) Pascal;

Умный дятел Гоша вот уже 10 часов без перерыва стучит по клавиатуре, набирая текст научной работы о видах вредителей хвойных деревьев и роли дятлов в

полном избавлении от них. Скорость набора текста Гошей – 100 стуков/минуту. Сколько байт информации настучит дятел, если для набора текста он использует компьютер выпуска 1995 года с операционной системой Windows’95, вывезенный в лес ввиду полного морального старения. ответ нужно дать в байтах

Написать в Паскаль.

Двухмерный массив размером M*N заполнить случайными целыми числами в интервале от -90 до 0. Вывести полученный массив на экран в виде таблицы. Найти количество элементов кратных 4 в последней строке.

Читайте также

Паскаль:

1) дана строка символов, в которой есть хотя бы вхождение 'abc'. Все вхождения 'abc' заменить на 'def'

2) в заданном тексте все встретившееся буквы 'a' удалить, а буквы 'd' удвоить

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.



Вы находитесь на странице вопроса "Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.