Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

1.дано целое k>2. напечатать все простые числа из диапазона [2,k]

10-11 класс

2.найти первое число Фибоначчи, большее заданного n (n>1).

Snezhka2002 25 авг. 2013 г., 8:09:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1n2b
25 авг. 2013 г., 8:58:46 (10 лет назад)

var a, b, k, j: integer;
begin
     readln(j);
     a := 1;
     b := 1;
     while (j > a) do
     begin
          k := b;
          b := b + a;
          a := k;
     end;
     writeln(a);
end.

Классно, что можно заставить бездушную машину работать на себя:))

Ответить

Читайте также

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
НАПИСАТЬ ПРОГРАММУ!ПОМОГИТЕ!!!

while и repeat
1)напечатать все отрицательные числа из диапазона от а до б, с шагом h.
2)Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.



Вы находитесь на странице вопроса "1.дано целое k>2. напечатать все простые числа из диапазона [2,k]", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.