Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дана программа, которая вычисляет значение многочлена x3 + 3x2 – 5x + 4

5-9 класс

при x=2
Var x, y: real;
Begin
x := 2;
y := x*x*x + 3*x*x – 5*x + 4;
writeLn(y)
End.
Оптимизируйте команду присваивания y := x*x*x + 3*x*x – 5*x + 4; что бы в ней было меньше арифметических операций.

Viktor1193 31 дек. 2013 г., 15:31:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Стефанияяяя
31 дек. 2013 г., 16:28:27 (10 лет назад)

Var x, y,xa,xb: real;
Begin
x := 2;
xa := x*x*x;
xb := x*x;
y := xa + 3*xb - 5*x + 4;
writeLn(y)
End.


+ 0 -
Evelina24032004
31 дек. 2013 г., 17:20:36 (10 лет назад)

Комментарий удален

+ 0 -
снегур84
31 дек. 2013 г., 18:57:10 (10 лет назад)

Комментарий удален

+ 0 -
щиночек
31 дек. 2013 г., 20:09:52 (10 лет назад)

Milinasamokhat, Это программированием называется, этому учиться надо)

+ 0 -
Volna85
31 дек. 2013 г., 22:40:09 (10 лет назад)

Комментарий удален

+ 0 -
Drago2014
01 янв. 2014 г., 1:32:15 (10 лет назад)

Я не знаю) Я например этому сам учусь и в школе меня этому никто не учит)))

Ответить

Читайте также

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль



Вы находитесь на странице вопроса "Дана программа, которая вычисляет значение многочлена x3 + 3x2 – 5x + 4", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.