Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составить алгоритм нахождения суммы 15 положительных чисел, которые генерируются случайным образом.(блок схемой)

5-9 класс

Morby 02 июня 2014 г., 19:17:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
серёгааааа
02 июня 2014 г., 19:59:40 (9 лет назад)

var a,s,i:integer;
begin
randomize;
s:=0;
for i:=1 to 15 do
begin
a:=random(100);
s:=s+a;
end;
write('s=',s);
end.

+ 0 -
Luneva713302
02 июня 2014 г., 21:40:03 (9 лет назад)

Program cnaiper;
uses crt;
const n=15;
var
  sum,t,i: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Числа:');
  randomize;
  sum:=0;
  for i:=1 to n do
    begin
      t:=random(100);
      sum:=sum+t;
      write (t:5);
    end;
  writeln();
  writeln('Сумма 15 чисел = ',sum);
end.

 

Блок-схема - во вложении

Ответить

Другие вопросы из категории

выделите попарно общие и единичные понятия и запишите их в соответствующие столбцы таблицы понятия композитор Пушкин художник Чайковский озеро горы Репин

поэт Байкал Париж Карпаты филосф город Сократ полководец Чита Суворов учёный река Ньютон Лена город

Читайте также

1. Дать определения понятиям: алгоритм, циклический алгоритм

2. Найдите значение х после выполнения алгоритма 1, если х=5.
3. Выполнить алгоритм 2. Занести значения переменных, изменяющихся в ходе выполнения алгоритма в таблицу.

4. Составьте алгоритм нахождения суммы всех двухзначных чисел, кратных трем, используя цикл с параметром

Составить алгоритм нахождения площади и длины окружности если известен радиус.

Составить алгоритм нахождения площади и длины окружности если известен диаметр.

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

1)среди 15 чисел найдите сумму всех положительных чисел

2) среди 15 чисел найдите количество всех чисел которые являются не отрицательными

1. найти сумму первых 10 чисел, кратных 7;

2. вывести на экран 11 первых чисел кратных 5;
3. составить программу рисования 18 прямоугольников синего цвета, координаты которых определяется случайным образом, а стороны равны а=140, b=40.



Вы находитесь на странице вопроса "Составить алгоритм нахождения суммы 15 положительных чисел, которые генерируются случайным образом.(блок схемой)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.