Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

реализовать задачу на компьютере, используя операторы цикла и вложеннные операторы цикла.

10-11 класс

задача. даны площади нескольких квадратов. найти длину диагонали самого большого из них.

801655 02 дек. 2014 г., 11:46:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Аидок5
02 дек. 2014 г., 14:23:55 (9 лет назад)

program MaxD;
// Вводятся площади квадратов, окончание ввода по значению 0
// Найти диагональ максимального размера.
// Поскольку диагональ равна квадратному корню из удвоенной площади,
// надо найти максимальную площадь, а затем вычислить диагональ.
var
  S,SMax:real;
begin
  SMax:=0;
  writeln('Вводите площади квадратов, 0 - конец ввода');
  repeat
    readln(S);
    if s>sMax then sMax:=s
  until s=0;
  writeln('Максимальная длина диагонали равна ',sqrt(2*sMax))
end.

Тестовое решение:

Вводите площади квадратов, 0 - конец ввода
5
10
12
13.6
11
18
0
Максимальная длина диагонали равна 6


+ 0 -
Evabevelikova
02 дек. 2014 г., 16:33:24 (9 лет назад)

блин..

+ 0 -
ROMA8Б
02 дек. 2014 г., 17:47:25 (9 лет назад)

что?

+ 0 -
Hamid1995
02 дек. 2014 г., 18:58:08 (9 лет назад)

Комментарий удален

+ 0 -
Angelina2234
02 дек. 2014 г., 21:51:07 (9 лет назад)

нет

+ 0 -
Giz20041
03 дек. 2014 г., 0:04:24 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

ОПРЕДЕЛИТЬ ЗНАЧЕНИЕ S ПОСЛЕ ВЫПОЛНЕНИ ОПЕРАНДОВ S:=1;

нц для i от 1 до 3

1.
10. Какие из перечисленных имен файлов

удовлетворяют маске ??a*сk*.*

Читайте также

Реализовать задачу на компьютере, используя операторы цикла

и вложенные операторы цикла. Составить блок схему.

Даны площади нескольких квадратов. Найти длину диагонали самого
большого из них.

Задача на турбо паскаль

составить таблицу кубов натуральных чисел от 1 до 15 Придусмотреть начало заголовка Использовать оператор цикла с параметром

Паскаль, 10 класс. Прошу срочно помочь. Заранее спасибо!

Задача №1:
Используя операторы цикла, рассчитать сумму ряда для значений x=0.5; 0.55; 0.6; 0.65; 0.7; 0.75. Включать в сумму члены ряда, большие или равные значению eps=0.00001. Проверить правильность вычислений для контрольной точки x=0.5. Сравнить полученные значения со значениями, рассчитанными по точному аналитическому выражению.
2x3(куб)/3-2x5/15+2x7/35-...+(-1)k+1*2x(2k+1)/4k2-1+..., f(x)=(1+x2)arctgx-x, f(0.5)=0.07955.

Задача №2:
Вводится последовательность целых чисел, по абсолютной величине меньших или равных 100. Найти и вывести на печать количество отрицательных чисел и среднее арифметическое значение всех чисел, расположенных после первого нулевого элемента.

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:



Вы находитесь на странице вопроса "реализовать задачу на компьютере, используя операторы цикла и вложеннные операторы цикла.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.