Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

программа на паскале.оператор цикла с параметром.задание:вычислить число S=S1+S2 S1=1+2+3+......N S2=1*2*3*.....N

10-11 класс

Spishu2013 22 июня 2015 г., 7:29:42 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Морячок1
22 июня 2015 г., 8:48:12 (8 лет назад)

var

i,s1,s2,s,n:integer;

begin

s1:=0;

s2:=1;

read(n);

for i:=1 to n do 

begin

s1:=s1+i;

s2:=s2*n;

end;

s:=s1+s2;

write (s);

end.

 

Ответить

Другие вопросы из категории

Читайте также

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Помогите плиз написать программы на Паскале)))

1.Составьте программу, проверяющую, верно ли
утверждение, что введенное вами целое число является четным.
2.



Вы находитесь на странице вопроса "программа на паскале.оператор цикла с параметром.задание:вычислить число S=S1+S2 S1=1+2+3+......N S2=1*2*3*.....N", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.