Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С клавиатуры вводится три строки вида Фамилия пробел Имя пробел Рост.Определить фамилию и имя самого высокого человека d pascal abc

5-9 класс

Kendal 17 мая 2013 г., 20:01:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Centerguf
17 мая 2013 г., 22:50:25 (10 лет назад)

type  str = array [1..100] of char;
var  maxs, tmps : str; 
count, max, tmp, ctmp : integer;

procedure reads (var s : str; var len, val : integer);
var 
b : boolean; 
 c : char; 
 i : integer;
begin 
 i := 0; b := false; 
 repeat 
  read (c); 
  if not b or (c <> ' ') then   
begin   
   if c = ' ' then b := true; 
    inc (i);   
   s[i] := c; 
    c := '1'; 
  end; 
 until b and (c = ' ');
  len := i; 
 readln (val);
end;
begin
assign (input, 'input.txt'); reset (input);
  reads (maxs, count, max); 
 while not eof do 
 begin   
 reads (tmps, ctmp, tmp);
    if tmp > max then   
 begin     
 max := tmp;
 count := ctmp; 
 maxs := tmps;
    end; 
end; 
 for tmp := 1 to count do write (maxs[tmp]);
end.



+ 0 -
Simka7771
17 мая 2013 г., 23:28:06 (10 лет назад)

Ну потому что 3 человека в 1 одну переменную тяжеловато в обработке да и правильно работать она вряд ли будет

+ 0 -
Apostolov
18 мая 2013 г., 1:58:43 (10 лет назад)

Если для 3их это не вопрос, я сейчас поем и напишу)

+ 0 -
Adameykozhunya
18 мая 2013 г., 2:56:23 (10 лет назад)

ты уже напиши

+ 0 -
Виктория072699
18 мая 2013 г., 3:33:07 (10 лет назад)

я просто уже не знаю что делать в ср сеестровка

+ 0 -
Prostobogdan
18 мая 2013 г., 4:54:50 (10 лет назад)

а - Иван Иванов, b - Павел Иванов, c - Сергей Иванов. И следовательно, а1 рост Ивана, b1 - рост Павла, c1 - рост Сергея, и сравнивать именно переменные а1...с1

Ответить

Другие вопросы из категории

Читайте также

Программа на Pascal ABC. С клавиатуры вводится маленькими русскими буквами строка, необходимо для каждого символа вывести, а) сколько раз его употребили и

б) частоту употребления (отношение а к длине строки, не считая пробелов).
Примечание 1. Выводить только для маленьких русских букв, пробелы не трогать.
Пример. Вводится строка 'раз два три'. нужно вывести:
р - 2 раза, ч.у - 0.27 //Округление до сотых
... Ну и так далее. Два раза один и тот же символ не выводить!
Вводить новые переменные можно в любом количестве.


с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.



Вы находитесь на странице вопроса "С клавиатуры вводится три строки вида Фамилия пробел Имя пробел Рост.Определить фамилию и имя самого высокого человека d pascal abc", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.