Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

НОД(А,Б,С)=НОД(НОД(А,Б),С) составьте программу нахождения наибольшего общего делителя трех чисел используя эту формулу

5-9 класс

Testbox156 21 янв. 2014 г., 4:14:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Isaeva1995
21 янв. 2014 г., 6:01:00 (10 лет назад)

var a, b, c, i: integer;
function gcd(a:integer; b:integer): integer; {алгоритм Евклида}
begin
     if a < b
     then
         begin
              i := a;
              a := b;
              b := i;
         end;
     if (b = 0) or (a = b)
     then
         gcd := a
     else
         gcd := gcd(b, a mod b);
end;

begin
     readln(a, b, c);
     i := gcd(a, b);
     i := gcd(i, c);
     writeln(i);
end.

Ответить

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "НОД(А,Б,С)=НОД(НОД(А,Б),С) составьте программу нахождения наибольшего общего делителя трех чисел используя эту формулу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.