Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ввести строку. На печать

10-11 класс

выдать слова, имеющие длину большую, чем длина первого слова строки.

Valkadaf 03 мая 2014 г., 22:46:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Мурусенька
04 мая 2014 г., 0:15:42 (10 лет назад)

var
  s: string;
  i, j, l, n: integer;
  NonFirst,FirstWrite: Boolean;

begin
  writeln('Введите строку');
  readln(s);
  NonFirst := false;
  FirstWrite:=True;
  i := 1;
  repeat
    j := PosEx(' ', s, i);
    if j > 0 then
      if NonFirst then begin
        if j-i>n then
          if FirstWrite then begin
            write(Copy(s,i,j-i));
            FirstWrite:=False
            end
          else write(' ',Copy(s,i,j-i));
        i:=j+1
      end
      else begin
        NonFirst := true;
        n := j - i;
        i := j + 1
      end
    else begin
      // последнее слово
      s:=Copy(s,i,length(s)-i+1);
      if length(s)>n then
        if FirstWrite then write(s)
        else write(' ',s)
    end
  until j = 0
end.

Тестовое решение:

Введите строку
Выдать слова, имеющие длину больше, чем первое слово введенной строки.
имеющие больше, введенной строки.

+ 0 -
Nikusha117
04 мая 2014 г., 2:31:21 (10 лет назад)

Комментарий удален

+ 0 -
вареники
04 мая 2014 г., 5:04:17 (10 лет назад)

Pascal

+ 0 -
Svetlanazotkina
04 мая 2014 г., 7:58:27 (10 лет назад)

Комментарий удален

+ 0 -
VerdandiUla
04 мая 2014 г., 9:01:43 (10 лет назад)

не имеет значения

Ответить

Читайте также

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с

наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.

помогите пожалуйста составить программу в Паскале!!

Сделать следущие задачи на языке pascal abc

#2. Ввести В. Если В<10, выдать на печать 2*В. Если В>=10, вычислить и напечатать значения функции y=x²-x+tg(1/B+x) для значений x, изменяющихся от –3 до 1, с шагом 0,1.
#3. Ввести массив целых чисел Х(n). Найти среднее арифметическое значений элементов массива, не принадлежащих интервалу [-2;2]. Если среднее арифметическое значение>2, заменить значения первого и последнего элементов на 1, в ином случае – на 0. Массив распечатать.
#4. Ввести массив А(n). Найти сумму положительных элементов массива, исключая при этом те элементы, которые кратны трём. Полученной суммой заменить элементы 2-ой половины массива. Массив отпечатать.

Нерввы на пределе, завтра сдавать, а в процедуре организовать не получается... Составить программу для решения следующей задачи: Дана строка.

Зашифровать ее, переворачивая каждое слово. Создать процедуры для разбиения строки на слова и записи слова в обратном порядке.

Привет, Вася!

!ясаВ ,тевирП



Вы находитесь на странице вопроса "Ввести строку. На печать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.