Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

5-9 класс

Написать программу, считывающую с клавиатуры
32-битное беззнаковое число n, числа a и b и
выводящую на экран число, равное исходному n, но с
установленным битом номер a и снятым битом номер b

СOBA 09 апр. 2017 г., 3:34:51 (6 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lollit
09 апр. 2017 г., 4:35:28 (6 лет назад)

#include <iostream>
using namespace std;

int main() {
    unsigned int n,a,b;
    cin>>n>>a>>b;
    n&=1<<a;
    n&=(0xFFFFFFFF)-(1<<b);
    cout<<n;
    return 0;
}
Что-то в этом духе

Ответить

Другие вопросы из категории

Алфавит племени Мульти состоит из 145 значков. Какое количество информации несёт один значок этого алфавита ? Каков информационный объём слова "Мышка" в ко

дировке ASCII (1 символ 1 байт) ? Сколько байт информации в книге из 46 страниц. На каждой странице 16 строк ,на каждой строку 21 символ ?

ПОМОГИТЕ УМОЛЯЮ

В чем особенность этого цикла?
While a<b
c:=a=b

Читайте также

Составить программы через Паскаль ABC

1. Дана длина ребра куба а. Найти объем куба V = a3 ( третья степень ) и площадь его поверхности S = 6 *a2. а = 2.00 V = 8.000 S = 24.000
2. Даны длины ребер a, b, c прямоугольного параллелепипеда. Найти его объем V = а*b*c
и площадь поверхности S = 2*( а*b + b*c + a*c ) a = 8.40 b = 3.80 c = 9.40 V = 300.048
S = 293.200
3. Найти длину окружности L и площадь круга S заданного радиуса R : L = 2*П (пи)*R, S = П (пи)*R2 (в квадрате) П = 3.14 R = 1.50 L = 9.420 S = 7.065

P.S *- умножение



Вы находитесь на странице вопроса "", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.