Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 971 ответов!

Помогите пожалуйста решить задачи в паскале. 1)найти сумму целых положительных чисел из промежутка от a до b кратных 4.a и b вводим с

5-9 класс

клавиатуры.

2)найти перевертышь трехзначного числа.

давид2345 27 авг. 2014 г., 5:18:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Катя13132
27 авг. 2014 г., 6:55:30 (9 лет назад)

1)

uses crt;

var a,b,i,sum:integer;

begin

read(a,b);

for i:=a to b do

if (i>0) and (i mod 4=0) then sum:=sum+i;

write(sum);

end.

2)

uses crt;

var i,n:integer;

    s,tmp:string;

begin

read(n);

tmp:=inttostr(n);

for i:=length(tmp) downto 1 do

s:=s+tmp[i];

write(s);

end.

Для ABC Pascal. Иначе функцию inttostr нужно будет заменить на str(n,tmp)

Ответить

Другие вопросы из категории

Срочно в 10 балов!!

Коля рассказывает Пете: «Я вчера смотрел кинофильм. Кинофильм мне понравился.» Объясните, общим или единичным в данной ситуации является понятие «кинофильм».

Частотный словарь русского языка — словарь вероятностей (частот) появления букв в произвольном тексте – приведен ниже. Определите, какое количество

информации несет каждая буква этого словаря.

Символ

Частота

Символ

Частота

Символ

Частота

Символ

Частота

о 0.090 в 0.035 я 0.018 ж 0.007
е, е 0.072 к 0.028 Ы, 3 0.016 ю, ш 0.006
а, и 0.062 м 0.026 ь, ъ, б 0.014 ц, щ, э 0.003
т, н 0.053 д 0.025 ч 0.013 ф 0.002
с 0.045 п 0.023 й 0.012
р 0.040 У 0.021 X 0.009
2. Используя результат решения предыдущей задачи, определите количество информации в слове “компьютер”.

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Помогите пожалуйста решить задачу с помощью паскаля.

1.-Выбрать наибольшее из двух чисел
2.-Найти сумму кубов чисел от 1 до 100
заранее спасибо:З



Вы находитесь на странице вопроса "Помогите пожалуйста решить задачи в паскале. 1)найти сумму целых положительных чисел из промежутка от a до b кратных 4.a и b вводим с", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.