Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите с программой, запросить последовательность n чисел и найти их сумму.

10-11 класс

Celibrik 13 авг. 2015 г., 4:38:40 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Atbaev
13 авг. 2015 г., 7:06:43 (8 лет назад)

var
sum, i, a, n: longint;

begin
readln(n);
for i := 1 to n do begin read(a);inc(sum, a); end;
writeln(sum);
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЙЛУСТА.№1)Для чего служит Панель инструментов в окне Microsoft Excel? 1) Для перехода в другие электронные таблицы. 2)Для выполнения

действий, которые невозможно сделать другими средствами. 3) Для выполнения различных действий, суть которых изображена на иконках,соответствующих каждой кнопке Панели!........... №2)Как обозначены столбцы на рабочем поле программы Excel? 1)Цифрами 2) рисунками 3)Буквами 4) Никак!....... №3 Как можно вставить лист в электронную таблицу? 1) При помощи меню Сервис 2) При помощи контекстно-зависимого меню работы с листами или при помощи меню Вставка 3) При помощи меню Формат!.... №4 Как сделать активной первую ячейку первого столбца? 1) Нажать одновременно клавиши Ctrl и Page Up на клавиатуре 2) Нажать одновременно клавиши Ctrl и Hote на клавиатуре или ввести в Поле имени ячейки А1. 3) Нажать на клавишу Hote на клавиатуре...№5 Как удалить один из листов электронной таблицы? 1) При помощи меню Сервис 2) При помощи меню Формат 3) При помощи контекстно-зависимого меню работы с листами или при помощи меню Правка.....

Читайте также

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Помогите, пожалуйста, очень, очень надо. Написать программу с помощью цикла, которая позволяет ввести с клавиатуры последовательность из трех

дробных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности. Ниже представлен рекомендуемый вид экрана во время работы программы:

*Обработка последовательности дробных чисел*

После ввода каждого числа нажмите <Enter>

- > 12.3

Введено чисел: 1 Среднее арифметическое: 12.30

- > 15

Введено чисел: 2 Среднее арифметическое: 13.65

- > 10

Введено чисел: 3 Среднее арифметическое: 12.43

Помогите написать программу в паскале!Очень надо!

Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"

const
N=20;
var
a:array [1..N] of integer;
i,j,max:integer;
begin
for i:= 1 to N do
readln(a[i]);
max:=99;
j:=a[i];
for i:= 1 to N do
if (j>99) and (j<999) and (j mod 9 <>0) and (j>max) then max:=j;
if max>99 then writeln (max) else writeln ('no');
readln;
end.

программа проверяет только последнее число, а не все 20. где ошибка?



Вы находитесь на странице вопроса "Помогите с программой, запросить последовательность n чисел и найти их сумму.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.