Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Даны переменные a, b, вывести все целые степени числа a от 1 до b. (программу записать в Паскале)

10-11 класс

Katysha1597 23 окт. 2015 г., 13:46:01 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Misin
23 окт. 2015 г., 14:43:20 (8 лет назад)

var
 a,b,c:integer;
begin
 c:=1;
 readln(a,b);
 while b<>0 do
 begin
  c:=c*a;
  write(c,' ');
  b:=b-1;
 end;
end.

+ 0 -
Kirillkuzmin2
23 окт. 2015 г., 16:21:54 (8 лет назад)

program z3;
var a, b, i, j: integer;
temp: int64;
begin
readln(a, b);
for i:=1 to b do begin       
 temp:=a;       
 for j:=1 to i-1 do begin               
  temp:=temp*a;       
 end;       
 write(temp, ' ');
end;
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЙЛУСТА.№1)Для чего служит Панель инструментов в окне Microsoft Excel? 1) Для перехода в другие электронные таблицы. 2)Для выполнения

действий, которые невозможно сделать другими средствами. 3) Для выполнения различных действий, суть которых изображена на иконках,соответствующих каждой кнопке Панели!........... №2)Как обозначены столбцы на рабочем поле программы Excel? 1)Цифрами 2) рисунками 3)Буквами 4) Никак!....... №3 Как можно вставить лист в электронную таблицу? 1) При помощи меню Сервис 2) При помощи контекстно-зависимого меню работы с листами или при помощи меню Вставка 3) При помощи меню Формат!.... №4 Как сделать активной первую ячейку первого столбца? 1) Нажать одновременно клавиши Ctrl и Page Up на клавиатуре 2) Нажать одновременно клавиши Ctrl и Hote на клавиатуре или ввести в Поле имени ячейки А1. 3) Нажать на клавишу Hote на клавиатуре...№5 Как удалить один из листов электронной таблицы? 1) При помощи меню Сервис 2) При помощи меню Формат 3) При помощи контекстно-зависимого меню работы с листами или при помощи меню Правка.....

Читайте также

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.

паскаль,1) вывести все четные числа от 1 до 15

2)вывести на экран числа от 2 до 9 с шагом 0,2



Вы находитесь на странице вопроса "Даны переменные a, b, вывести все целые степени числа a от 1 до b. (программу записать в Паскале)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.