Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

срочно

10-11 класс

Секретный замок для сейфа состоит из 10 расположенных в ряд ячеек, в которые надо вставить игральные кубики. Но дверь открывается только в том случае, когда в любых трех соседних ячейках сумма точек на передних гранях кубиков равна 10. (Игральный кубик имеет на каждой грани от 1 до 6 точек.) Напишите программу, которая разгадывает код замка при условии, что два кубика уже вставлены в ячейки

Af0nya 19 июля 2013 г., 4:13:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andysixx1202
19 июля 2013 г., 5:53:48 (10 лет назад)

var
  a: array [1..10] of integer;
  i: integer;
begin
  readln(a[1], a[2]);
  write('Код замка: ', a[1], ' ', a[2], ' ');
  for i := 3 to 10 do
  begin
    a[i] := 10 - (a[i - 1] + a[i - 2]);
    write(a[i], ' ');
  end;
end.

+ 0 -
Бэйба1171
19 июля 2013 г., 8:34:14 (10 лет назад)

var
  n1, n2, n3: integer;
begin
  write('Введите очки на двух первых кубиках: ');
  readln(n1, n2);
  n3 := 10 - (n1 + n2);
  writeln('Замок имеет код ', n1, n2, n3, n1, n2, n3, n1, n2, n3, n1);
end.

Тестовое решение:

Введите очки на двух первых кубиках: 3 5
Замок имеет код 3523523523


Ответить

Читайте также

Помогите срочно!!

Даю 20 баллов

помогите пожалуйста написать программу!!!СРОЧНО!!!

в одномерном массиве все отрицательные элементы заменить модулем, а положительные заменить числом 888



Вы находитесь на странице вопроса "срочно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.