Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

ПЛИИЗЗЗ СРОЧНОО Дан массив D(n). Удалите из массива все элементы, равные минимальному. Выведите на экран исходный и полученный массивы.

10-11 класс

775634 30 нояб. 2015 г., 18:05:18 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BigEggs
30 нояб. 2015 г., 19:00:44 (8 лет назад)

const n=5;
var
i,x,q:integer;
d:array [1..n] of integer;
begin
writeln ('Заполните массив);
for i:=1 to n do
read (d[i]);
x:=d[1];
for i:=2 to n do
if x>d[i] 
then x:=d[i];
writeln ('Минимальный элемент :',x);
for i:=1 to n do
write (' ',d[i]);
writeln;
for i:=1 to n do 
if d[i]<>x 
then begin
q:=q+1; 
d[q]:=d[i]; 
end;
for i:=1 to q do 
write (' ',d[i]);
end.

Должно быть так. 
P.s. Программа написана на языке Pascal ABC.

Ответить

Другие вопросы из категории

Паскаль. Помогите, ребят. 1) Вывести на экран все трехзначные числа, числа которых расположены в порядке возрастания. Например, 123, 456, 789.

2) Заполните двумерный массив 4х5 случайными вещественными числами из диапазона [–1; 1]. Выведите его на экран. Подсчитайте общее количество неотрицательных элементов массиве.

3) Заполните двумерный массив 3х4 целыми числами с клавиатуры. Выведите его на экран. Найдите сумму элементов каждой строки.

Читайте также

1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и

полученную сумму.
2. Дан массив В(n). Определите произведение элементов, кратных 3. Выведите на экран исходный массив и найденное произведение.

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

Дан массив целых чисел из n

элементов, заполненный случайным образом числами из промежутка [-10,60]. Удалить из него все элементы, в
которых последняя цифра нечетная, а само число кратно 3.
Помогите пожалуйста решить в C# (Си шарп)

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ -20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.
Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).
Поменять местами первый положительный и последний отрицательный элементы.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы



Вы находитесь на странице вопроса "ПЛИИЗЗЗ СРОЧНОО Дан массив D(n). Удалите из массива все элементы, равные минимальному. Выведите на экран исходный и полученный массивы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.