Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

В Pascal ABC с помощью циклического алгоритма FOR нужно решить: 1) Найти количество чисел от a до b, делящихся без остатка на 3 и 4

10-11 класс

одновременно.

2) Вывести все двузначные числа, в записи которых есть цифра N. Включить проверку на то, что N является однозначным числом.

Qybik 02 мая 2016 г., 12:12:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elebelyakova
02 мая 2016 г., 12:45:04 (7 лет назад)

var a,b,i,n:integer;
Begin
    read(a,b);
    for i:= a to b do
        if i mod (3*4) = 0 then n:=n+1;
    writeln(n);
End.

var n,i:integer;
Begin
    for i:= 1 to 99 do begin
        if (i div 10 <> 0) and ((i div 10 = n) or (i mod 10 = n)) then
            write(i,' ');
    end;
End.

Ответить

Другие вопросы из категории

Решите 2 задачи в Паскале! Плииз! 1) Вывести на экран нарутальные числа от 1 до 100, которые при делении на 6 дают в остатке 4, и их

колличество. Конец программы:

SumChis :=0;

for i:1 to 100

if i mod 6 = 4 then

begin

writeln (i);

SumChis :=SumChis +1;

end.

Написать надо начало программы!

2) Написать программу, которая выводит натуральные числа до 10 000 включительно, которые при делении на 17 дают остаток 11 или B

Помогите решить, будьте добры

Ответ равен 65536. Объясните решение.

Читайте также

Program_v1;

var A: array [1..20] of integer;

i,s:integer;

begin

randomize;

s:=0;

for i:=1 to 20 do

begin

A[i]:=random(100);

write (' ',A[i] ');

end;

for i:=1 to 20 do

if imod2>0 then

s: = a[i]*a[i];

writeln;

writeln('s=',s);

readln;

end.
генератором случайных чисел (от 0 до 100) задан массив из 20 целых
чисел.составьте программу, с помощью которой напечатайте на одной
строчке исходный массив, а на следующей строке - сумму квадратов
элементов с начетными индексами

TURBO Pascal

var
i,N:integer;
begin
writeln('Vvedite N');
readln(N);
for i:=1 to n do
if (i mod 2<>0)and(i mod 3<>0)and(i mod 5<>0)then writeln(i);
readln
end.

Данная программа выдает все числа, от 1 до заданного (n), которые не делятся без остатка на 2,3,5. что нужно исправить, чтобы программа выдавала только количество этих чисел.
Заранее спасибо.



Вы находитесь на странице вопроса "В Pascal ABC с помощью циклического алгоритма FOR нужно решить: 1) Найти количество чисел от a до b, делящихся без остатка на 3 и 4", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.