Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

СРООЧНОО! Напишите код в турбо паскаль

10-11 класс

Дан текст, в котором записано одно из стихотворений
А.С. Пушкина. Сколько раз встречаются гласные буквы?

Burger2001 16 мая 2016 г., 8:42:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gulik55
16 мая 2016 г., 9:53:42 (7 лет назад)

Это PascalABC, но на должно сработать и на турбе)

var

  s: string;
  i: longint;
  j: byte;

begin
  writeln('Конец стиха - строка пустая');
  repeat
    for j := 1 to length(s) do
      if (lowcase(s[j]) in ['а', 'е', 'ё', 'и', 'о', 'у', 'ы', 'э', 'ю', 'я']) then
        i := i + 1;
    readln(s);
  until s = '';
  writeln(i, ' гласных букв');
end.

Ответить

Другие вопросы из категории

В Pascal ABC с помощью циклического алгоритма FOR нужно решить: 1) Найти количество чисел от a до b, делящихся без остатка на 3 и 4

одновременно.

2) Вывести все двузначные числа, в записи которых есть цифра N. Включить проверку на то, что N является однозначным числом.

Решите 2 задачи в Паскале! Плииз! 1) Вывести на экран нарутальные числа от 1 до 100, которые при делении на 6 дают в остатке 4, и их

колличество. Конец программы:

SumChis :=0;

for i:1 to 100

if i mod 6 = 4 then

begin

writeln (i);

SumChis :=SumChis +1;

end.

Написать надо начало программы!

2) Написать программу, которая выводит натуральные числа до 10 000 включительно, которые при делении на 17 дают остаток 11 или B

Читайте также

Срочно! Помогите пожалуста! Нужно написать програмный код в турбо паскале! Заранее ОГРОМНОЕ СПАСИБО!! Заполнить массив из 10 элементов

случайными числами в интервале от 0 до 4 и вывести номера всех элементов, равных X.

Пример:

Исходный массив:

4 0 1 2 0 1 3 4 1 0

Что ищем? 0

A[2], A[5], A[10]

Решать задачу нужно на древнем ТП7 (Турбо паскаль).

Вычислить сумму элементов каждой строки, вводимого С КЛАВИАТУРЫ ДВУМЕРНОГО массива. Обязательно с клавиатуры. Напишите программу пожалуйста.

СРОЧНО!!! Помогите пожалуйста с турбо паскаль, задание на тему циклы....

Как мне препод объясняла там должно быть for i:=1 to N do begin
P:P*(2*i)/(2*i+1)
end;
Вот часть которую нужно как то применить к этому заданию...
Как будет выглядеть весь код?)))



Вы находитесь на странице вопроса "СРООЧНОО! Напишите код в турбо паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.