Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Программа: pascal abc. Задание: дана строка, написать программу, вставляющую после каждой точки символ пробела.

10-11 класс

Nsta0016 16 февр. 2017 г., 2:10:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ligerko73
16 февр. 2017 г., 4:59:50 (7 лет назад)

var s: string;   
     i: integer;
begin 
read(S); 
i:=1; 
while i<=length(s) do begin 
if s[i]='.' then insert(' ',s,i+1); 
inc(i); 
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

составить типо дерево потомком маномаха. <html> <head> <title>Скворцова 10в </title> </head>

<body bgcolor = "# F0FFFF">

<font color ="red" size="+4">

<center> <b>Потомки Владимира Мономаха </b></font>
</center>


<ol>
<li> <font color="yellow" size="+3">Мстислав(1132) </font>

<ol><li type ="circle"> Изяслав Волынский(1154)</li>

<ol><li type ="square"> <font color ="pink">Мстислав (1170)</li></font></ol>

<li type ="circle"> Всеволад Новгородский (1138)

<li type ="circle"> Растислав Смоленский (1168)

<ol><li type ="square"> Роман (1180)

<li type ="square">Рюрик (1215)

<li type ="square"> Давид (1197)

<li type ="square"> Мстислав Храбрый (1180)</ol></li>

а дальше не знаю ,помогите люди добрые

Читайте также

язык Pascal ABC. Напишите программу:

Дан двухмерный массив A[1..m,1..n]. Написать программу построения одномерного массива B[1..m], элементы которого соответственно равны суммам элементов строк.

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите пожалуйста,1. Дан символ. Написать программу, выводящую его код.

2. Дан код символа. Написать программу, выводящую сам символ.
3. Написать программу для вывода на экран всех маленьких латинских букв.



Вы находитесь на странице вопроса "Программа: pascal abc. Задание: дана строка, написать программу, вставляющую после каждой точки символ пробела.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.