Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

5-9 класс

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1234567880987 31 марта 2015 г., 13:59:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akoshelev
31 марта 2015 г., 14:58:54 (9 лет назад)

Язык Паскаль.

Program Ski;

const n=5; {длина массива}

var: a:array [1..n] of integer; i,s:integer;

begin

For i:=1 to n do begin

                          Writeln('vvedite element massiva nomer ',i);

                          Read(a[i]);

                        end;    {Тут мы просим пользователя ввести элементы}

s:=0; {s - это указанная тобой сумма. Мы ее соответственно обнуляем сначала}

for i:=1 to n do begin

                          if a[i] mod 10=0 then s:=s+a[i];  

                       end;    

 

{ берем каждый элемент массива, и проверяем, делится ли он на 10 без остатка(mod- это остаток от деления на указанное число). Если все в порядке, тогда прибавляем число к общей сумме }

 

Writeln('summa elementov ravnih nulu ',s);  {пишет ответ}

readln; {чтобы сразу не закрывалась программа}

end.

 

Если возникнут вопросы или появится еще подобное задание для решения, пиши прямо в личку. Мне все равно делать нечего )

Ответить

Другие вопросы из категории

Visual Basic

Сделать проэкт, в котором для введеного пользователем натурального показателя степеня n вычислялось значение 2^n

Приведите 2-3 примера пар объектов,

имена отношений которых не изменяются, когда меняются местами имена объектов.

Установите соответствие.

Читайте также

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Программа в Паскале! "Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел .

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000."

Отдал все пункты что есть! Помогите!

Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел.Программа получает на вхо

д количество чисел в последовательности, а затем сами числа.Количество чисел не превышает 1000. Введённые числа не превышают 30 000.Программа должна вывести одно число – количество двузначных чисел в заданной последовательности натуральных чисел.

ПОМОГИТЕ ПОЖАЛУЙСТА, ЗАДАЧА ОЧЕНЬ ПРОСТАЯ!!!

Написать программу, которая в последовательности натуральных чисел определяет сумму чисел оканчивающихся на 3. Программа на вход получает сначала кол-во чисел в последовательности, а затем сами числа. Кол-во чисел не превышает 100, а введенные числа не превышают 300.



Вы находитесь на странице вопроса "Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.