Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

написать класс который принимает с клавиатуры целое число и выводит на экран три предыдущих ему целых числа причем каждое в отдельной строке

10-11 класс

Gfwfy12345 25 сент. 2013 г., 8:52:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aриночка2000
25 сент. 2013 г., 10:29:37 (10 лет назад)

type Cl = class
  a:integer;
  constructor Create(b:integer);
  procedure SetVal(b:integer);
  function GetVal:integer;
  procedure GetPrev;
end;

constructor Cl.Create(b:integer);
begin
  a := b;
end;

procedure Cl.SetVal(b:integer);
begin
  a := b;
end;

function Cl.GetVal:integer;
begin
  GetVal := a;
end;

procedure Cl.GetPrev;
var
 Pr, i:integer;
begin
  writeln('Три предыдущих');
  Pr := Pred(a);
  for i := 1 to 3 do
  begin
   writeln(Pr, ' ');
   Pr := Pred(Pr)
  end;
end;


var
  Obj:Cl;
begin
  Obj := Cl.Create(5);
  Obj.GetPrev;
  writeln;
  Obj.Destroy;
end.
 

Ответить

Другие вопросы из категории

Читайте также

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0



Вы находитесь на странице вопроса "написать класс который принимает с клавиатуры целое число и выводит на экран три предыдущих ему целых числа причем каждое в отдельной строке", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.