Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

2.Вычислить y={3,если x-1>/ ,4,если x-1<0 помогите пожалуйста!!! :)

10-11 класс

German123 01 дек. 2013 г., 1:19:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Амаймончик
01 дек. 2013 г., 3:22:58 (10 лет назад)

Если я правильно понял условие: y=3 при x-1>0 и y=4 при x-1<0 (при этом не сказано, что делать при x-1=0), то решение будет выглядеть так (если требуется написать программу на паскале):

Var x,y:integer;
Begin
 write('x=);
 readln(x);
 if (x-1)>0 then y:=3;
 if (x-1)<0 then y:=4;
 writeln('y=',y);
End.

Но я бы посоветовал изменить строку if (x-1)>0 на if (x-1)>=0, иначе при (x-1)=0 программа будет работать некорректно.

Ответить

Другие вопросы из категории

Надо решить следующую задачу:

Найти минимальное число из 10 случайных чисел. Диапазон генерации случайного числа задается
пользователем в начале работы программы.
(использовать форматированный ввод/вывод)

Читайте также

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.

Заданы размеры сторон a, b, c некоторой детали в виде параллелепипеда, количество штук деталей K, размеры сторон тары для упаковки деталей, имеющей также

форму параллелепипеда A, B, C. Вычислить объем детали v, объем тары V, необходимое количество тары N для упаковки деталей количеством K штук. Если N>10, то вычислить отношение объема детали к объему тары .
Помогите пожалуйста написать это В Паскале.



Вы находитесь на странице вопроса "2.Вычислить y={3,если x-1&gt;/ ,4,если x-1&lt;0 помогите пожалуйста!!! :)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.