Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Создать текстовый файл,

10-11 класс

состоящий из 2-3 предложений. Определить, есть ли в нем английские слова и
сколько.

Alina191125bil 15 дек. 2013 г., 13:49:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
алёна1123
15 дек. 2013 г., 14:28:49 (10 лет назад)

Предполагается, что файл имеет имя d:\f.txt. 
var
  i,n:integer;
  s:string;
  f:text;
begin
assign(f,'d:\f.txt');
reset(f);
readln(f,s);
repeat
  if s[1] in ['a'..'z','A'..'Z'] then n:=n+1;
  i:=pos(' ',s);
  delete(s,1,i);
  until i=0;
writeln('Английских слов: ',n);
end.

+ 0 -
Doceressa
15 дек. 2013 г., 16:58:45 (10 лет назад)

текст

+ 0 -
Natatokareva1
15 дек. 2013 г., 19:16:56 (10 лет назад)

на диске

+ 0 -
Dantol01
15 дек. 2013 г., 21:06:18 (10 лет назад)

сделанный через блокнот

+ 0 -
Lizzybraun
15 дек. 2013 г., 22:42:10 (10 лет назад)

Ясно, сделаю попозже

+ 0 -
Alexbaku
15 дек. 2013 г., 23:36:17 (10 лет назад)

хорошо, спасибо)

Ответить

Другие вопросы из категории

Надо решить следующую задачу:

Найти минимальное число из 10 случайных чисел. Диапазон генерации случайного числа задается
пользователем в начале работы программы.
(использовать форматированный ввод/вывод)

Читайте также

Всем Привет!1. В текстовом файле хранятся квадратные целочисленные матрицы

порядка n. Преобразовать
файл, удалив из каждой матрицы элементы побочной диагонали.

1) Скорость передачи данных через ADSL-соединение равна 1024000 бит/c. Передача файла через данное соединение заняла 5 секунд. Определите размер файла

в килобайтах.

2) Скорость передачи данных через ADSL-соединение равна 256000 бит/c. Передача файла через это соединение заняла 2 минуты. Определите размер файла в килобайтах.

3) Сколько секунд потребуется обычному модему, передающему сообщения со скоростью 28800 бит/с, чтобы передать цветное растровое изображение размером 640х480 пикселей, при условии, что цвет каждого пикселя кодируется тремя байтами?

4) Скорость передачи данных через модемное соединение равна 51 200 бит/с. Передача текстового файла через это соединение заняла 10 с. Определите, сколько символов содержал переданный текст, если известно, что он был представлен в 16-битной кодировке Unicode.

5) Скорость передачи данных через ADSL-соединение равна 128000 бит/с. Передача текстового файла через это соединение заняла 1 минуту. Определите, сколько символов содержал переданный текст, если известно, что он был представлен в 16-битной кодировке Unicode.

6) Информационное сообщение объемом 2.5 Кбайт передается со скоростью 2560 бит/мин. За сколько минут будет передано данное сообщение?

Открыть в редакторе Microsoft Word произвольный текстовый файл (без графических

элементов), определить количество символов в этом файле, включая пробелы (команда
Файл —» Свойства), и вычислить количество информации в этом файле.

1)

Скорость передачи данных через модемное
соединение равна 51 200 бит/с. Передача текстового файла через это соединение
заняла 10 с. Определите, сколько символов содержал переданный текст, если
известно, что он был представлен в 16-битной кодировке Unicode.



Вы находитесь на странице вопроса "Создать текстовый файл,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.