Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста !!!!Написать программу на языке Pascal решения квадратного уравнения. Программа должна проверять правильность введенных

5-9 класс

пользователем данных и в случае, если коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение.

Анастейша7 14 февр. 2014 г., 22:48:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maratovich
15 февр. 2014 г., 1:42:27 (10 лет назад)

var a,b,c,d:integer; x1,x2:real;
begin
writeln('Введите коэффициенты');
readln(a,b,c);
d:=b*b-4*a*c;
if (d<0) then writeln('Нет решения')
else if (d=0) then
begin
x1:=-b/(2*a);
writeln('x=',x1);
end
else begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln('x1= ',x1,'x2=',x2);
end;

readln
end.

Ответить

Читайте также

. Написать программу на языке Pascal решения квадратного уравнения. Программа должна проверять правильность введенных пользователем данных и в случае,

если коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение. Помогите очень нужно

Ребята,помогите пожалуйста!!!))) суть задания: Составьте блок-схему и программу на языке VBA, которая вычисляет сумму первых n целых положительных четных

чисел. Количество суммируемых
чисел должно вводиться во время работы программы. Программа должна
проверять правильность введенных пользователем данных и, если они неверные ( n ≤ 0 ), выдавать сообщение об ошибке.
Буду очень признательна, если кто-нибудь возьмется за это задание. Спасибо)

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите решить задачку в паскале ! Пожалуйста !

Составить программу на языке Pascal для решения следующей логической задачи.
По графику нужно написать задачу и решение, график прилагается.

Написать программу на языке программирования Pascal.

Перевод дюймов в сантиметры (1дюйм=2,54см). Нужно, чтобы при запуске программы на экране выходило в два столбика дюймы и сколько это будет сантиметров. До 20 чисел. Через оператор While.



Вы находитесь на странице вопроса "Помогите пожалуйста !!!!Написать программу на языке Pascal решения квадратного уравнения. Программа должна проверять правильность введенных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.