Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Срочно! Pascal ABC, написать две программы по циклическим алгоритмам и массивам. Зараннее спасибо! См. приложенные скриншоты.

10-11 класс

p.s.

Где П- произведение.

ANNania 08 мая 2015 г., 7:23:31 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nirina2004
08 мая 2015 г., 9:57:28 (8 лет назад)

1) Первую я мог немного неправильно понять, проверь, так ли:

uses crt;
var i:integer;
s:real;
begin
s:=1;
for i:=1 to 10 do begin
s:=s*(2+1/i);
end;
writeln(s);
end.

 

2) Числа в матрице А задаются случайно от 1 до 9 включительно

uses crt;
var a:array[1..99,1..99] of integer;
c:array[1..99,1..99] of integer;
i,j,n:integer;
begin
write('Введите число n: ');
readln(n);
writeln('Исходная матрица:');
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=random(9-1+1)+1;
write(a[i,j]:2);
end;
writeln;
end;
writeln('Изменённая матрица:');
for i:=1 to n do begin
for j:=1 to n do begin
if j<i then c[i,j]:=a[i,j]
else c[i,j]:=-a[i,j];
write(c[i,j]:3);
end;
writeln;
end;
end.

Ответить

Другие вопросы из категории

Написать

функцию, которой передаются координаты точки (x, y) и которая определяет,
попадает ли точка в заштрихованную область на рисунке через PHP

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. С клавиатуры вводится целое число X. Опишите на

русском языке или на одном из языков программирования алгоритм, который находит и выводит наименьший номер элемента, равного X, или сообщение, что такого элемента нет.
const N=30;


var a: array [1..N] of integer;


i, j, x: integer;

Помогите решить задачи

Читайте также

Написать программу (в Pascal) и составить блок-схему по задаче: В двумерном массиве произвольной размеренности подсчитать количество элементов, равных

наибольшему элементу в этом массиве. Вывести значение наибольшего элемента.

Pascal ABC написать программу
Pascal ABC

1. Дан двумерный числовой массив A состоящий из 35*35 элементов. Написать программу для нахождения количества значений элементов массива меньших среднего арифметического значения элементов массива.

2.Дан двумерный числовой массив A состоящий из 15*100 элементов. Написать программу для нахождения количества элементов массива делящихся на 13 без остатка.



Вы находитесь на странице вопроса "Срочно! Pascal ABC, написать две программы по циклическим алгоритмам и массивам. Зараннее спасибо! См. приложенные скриншоты.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.