Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Заработок рабочих на фабрике составил М рублей. Его надо разделить поровну между всеми рабочими (все необходимые значения введите с клавиатуры).

1-4 класс

Zamzagulgalimo 01 июля 2014 г., 6:20:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Linusdu
01 июля 2014 г., 8:20:23 (9 лет назад)

program gt;
var n,m:integer;
begin
writeln('Ввести кол-во рабочиз');
readln(n);
writeln('ввести сколько денег есть всего');
readln(m);
writeln('Ответ:',n/m);
end.

+ 0 -
Valeriy2001
01 июля 2014 г., 10:52:15 (9 лет назад)

даже если вывод будет вещественным?

+ 0 -
Anonimovad
01 июля 2014 г., 12:01:46 (9 лет назад)

или с копейками с и округлит если будет нецелое число копеек?

+ 0 -
Mrnecky
01 июля 2014 г., 13:27:28 (9 лет назад)

Не умею кодить, но могу написать на русско-программистском языке, чтобы можно было "перевести" на программный код: объявить переменные: кол-во рабочих, зарплата; спросить ввод с клавиатуры "введите кол-во рабочих" и записать ответ в переменную "кол-во рабочих"; спросить ввод с клавиатуры "введите зарплату" и записать ответ в переменную "зарплата"; объявить переменную "ответ"; установить значение переменной "ответ" на значение, равное зарплате, поделённой на кол-во рабочих; вывести на экран ответ

+ 0 -
89168685064
01 июля 2014 г., 14:20:59 (9 лет назад)

я говорю что если при делении денег на кол-во рабочих оказалось нецелым всё равно вывести этот ответ или нет?

+ 0 -
Strazhnitsa
01 июля 2014 г., 16:27:05 (9 лет назад)

ок,решу как есть

Ответить

Читайте также

Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа

больше 100, то замените каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.



Вы находитесь на странице вопроса "Заработок рабочих на фабрике составил М рублей. Его надо разделить поровну между всеми рабочими (все необходимые значения введите с клавиатуры).", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.