Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано четырехзначное число.Определить:кратно ли произведение его цифр числу а.ПОЖАЛУЙСТА ПОМОГИТЕ!

5-9 класс

Kozhurova2001 03 дек. 2014 г., 0:28:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zinyakova96
03 дек. 2014 г., 1:16:14 (9 лет назад)

var
st:string;
i,a,pr:integer;
begin
readln(st,a);
pr:=1;

for i:=1 to 4 do

pr:=pr*(ord(st[i])-ord('0'));

writeln(pr mod a=0);
end.

Ответить

Читайте также

Напишите программу на паскале)

1.С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше.
2.С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом.
3.С клавиатуры вводится 4-хзначное число. Определить, равна ли сумма первых двух цифр сумме последних двух.

Домашнее задание:

1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет
сумму и произведение его цифр.



Вы находитесь на странице вопроса "Дано четырехзначное число.Определить:кратно ли произведение его цифр числу а.ПОЖАЛУЙСТА ПОМОГИТЕ!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.