Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Сколько существует трёхзначных чисел сумма цифр которых делится на 5? Вывести их.

5-9 класс

Программа паскаль

Djat1999 25 июня 2015 г., 6:46:33 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elizavetar17
25 июня 2015 г., 9:20:00 (8 лет назад)

var
i, a, k, sum : integer;
begin
k:=0; 
for i:=100 to 999 do   
begin   
sum:=0;   
a:=i;   
while a>0 do     
begin     
sum:=sum+(a mod 10);     
a:=a div 10;     
end;     
if sum mod 5 = 0 then       
begin       
inc(k);       
write(i:5);       
end;   
end;   
writeln;   
writeln('Количество чисел: ', k);
end.

+ 0 -
231241243
25 июня 2015 г., 12:02:24 (8 лет назад)

программу надо написать

+ 0 -
Migilin
25 июня 2015 г., 12:56:31 (8 лет назад)

101 102.103,104,105,764,982,435.478,856,.............

+ 0 -
Faita
25 июня 2015 г., 15:11:45 (8 лет назад)

да не надо просто числа писать программу надо

+ 0 -
Vika2OO4
25 июня 2015 г., 17:30:08 (8 лет назад)

543 Па

+ 0 -
Semashko85
25 июня 2015 г., 19:04:30 (8 лет назад)

начинать надо так: program summa(это название программы и так далее надо написать программу)

Ответить

Другие вопросы из категории

Что такое высказывание
Петя и Коля играют в следующую игру: Петя задумы­вает правило преобразования целых чисел. Коля мо­жет называть Пете любые числа и узнавать

результаты преобразования. Задача Коли — отгадать это правило. Ниже приведены вопросы Коли и ответы Пети в нескольких таких играх. Попробуйте отгадать, какое правило задумал Петя в каждой игре.

запишите на языке паскаль следующие условия:

0 x не равно 10
величины x и y -Положительны
x>0
X€[O;4]
x € (-5;5]
x € [o;+ знак бесконечности )
величина x -чётная
величина x -нечётная
x кратно 3
x делится без остатка на 2 и на 3
x не делится на 5



Вы находитесь на странице вопроса "Сколько существует трёхзначных чисел сумма цифр которых делится на 5? Вывести их.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.