Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Напишите програму нахождения суммы большого и меньшего из 3 чисел.

5-9 класс

Demon1002 12 сент. 2015 г., 20:50:51 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kozerog9494
12 сент. 2015 г., 22:00:09 (8 лет назад)

program sum;

+ 0 -
Enneigard
12 сент. 2015 г., 22:40:34 (8 лет назад)

var

  a, b, c, min, max : real;

begin

  read (a, b, c);

 

  if (a >= b) and (a >= c) then max := a

  else  if (b >= a) and (b >= c) then max := b

  else max := c;

  

 if (a <= b) and (a <= c) then min := a

  else  if (b <= a) and (b <= c) then min := b

  else min := c;

 

  writeln (min + max);

end.

Ответить

Другие вопросы из категории

решите пожалуйста!!!
Напишите даты. 1.Изобретение технологии изготовления бумаги в Китае. 2.Начало книгопечатания в Европе. 3.Появление алфавитного

письма.

4.Появление первых лазерных дисков.

5.Первые следы иерогливического письма в Древнем Египте.

6.Начало книгопечатания в России

7.Появление первых жёстких дисков для компьютеров.

8.Изобретение магнитофона.

9.Изобретение фотографии.

10.Первая запись звука с помощью фонографа.

11.Демонстрация первого фильма.

Читайте также

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2



Вы находитесь на странице вопроса "Напишите програму нахождения суммы большого и меньшего из 3 чисел.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.