Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

СРОЧНО ПОЖАЛУЙСТА ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ

5-9 класс

1).найти все четырехзначные числа,делящиеся на 27.
2).дан массив целых чисел,состоящий из 20 элементов.Заполнить его случайными числами и найти количество элементов массива. значения которых больше заданного числа и кратны 5.

Ungsam611 19 апр. 2014 г., 13:55:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
IrinatmnMEI
19 апр. 2014 г., 16:33:05 (10 лет назад)

Первая задача
var
i: integer;
begin
for i:=1000 to 9999 do
 begin
  if (i mod 27)=0 then writeln(i);
 end;
 end.

Вторая задача
var
a: array [1..21] of integer;
i, j, n: integer;
begin
write('Сгенерированый массив: ');
for i:=1 to 20 do
 begin
 a[i]:=random(100);
 write(a[i], ' ');
 end;
writeln;
write('Введите число: ');
readln(n);
for i:=1 to 20 do
 if (a[i]>n) and ((a[i] mod 5)=0) then inc(j);
 write(j);
end.

+ 0 -
ДарьяСолнце
19 апр. 2014 г., 17:10:52 (10 лет назад)


Program  Ilgiz98;
var
  i: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Программа находит 4-значные числа, которые делятся на 27');
  writeln('Список таких чисел:');
  for i:=1000 to 9999 do
    if (i mod 27)=0 then writeln(i);
end.

Program  Ilgiz98;
var
  mass: array [1..20] of integer;
  i, k, n: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Среди элементов массива программа находит числа, которые больше заданного числа N и одновременно кратны 5');
  write('Введите число N ');  readln (n);
  writeln('*** Вычисляю... ***');
  k:=0;
  writeln('Массив чисел:');
  for i:=1 to 20 do
    begin
     mass[i]:=random(1000)-500;
     writeln(mass[i]);
     if (mass[i]>n) and ((mass[i] mod 5)=0) then k:=k+1;
  end;
  writeln();
  writeln('Всего найдено ',k,' таких чисел');
end.

+ 0 -
киса2903
19 апр. 2014 г., 18:35:57 (10 лет назад)

УРА

+ 0 -
Glassmans3
19 апр. 2014 г., 20:30:33 (10 лет назад)

Насчёт первой задачи. Нет таких симметричных четырёх значных чисел, которые делятся на 27

+ 0 -
Azatyan9
19 апр. 2014 г., 22:45:53 (10 лет назад)

1. НАЙТИ ВСЕ ЧЕТЫРЕХЗНАЧНЫЕ ЧИСЛА,ДЕЛЯЩИЕСЯ НА 27.

+ 0 -
Vasilij1342
20 апр. 2014 г., 0:42:42 (10 лет назад)

ОШИБКА ИЗВИНИ

+ 0 -
Drakoscha88
20 апр. 2014 г., 2:29:47 (10 лет назад)

Хорошо, пишу

Ответить

Другие вопросы из категории

вставте пропущенные устройства.

Я включил компьютер и набрал на ... сочинение про свою семью. Затем я переписал с ... последние фотографии, добавил их к тексту и вывел сочинение на ... . После этого я прибавил громкость звука ... и стал играть в любимую игру, быстро двигая ... . Получив рекордный результат, я ввёл с ... своё имя и распечатал на ... список рекордсменов.

Читайте также

СРОЧНО ПОЖАЛУЙСТА ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ

1).найти все симметричные четырехзначные числа,делящиеся на 27.
2).дан массив целых чисел,состоящий из 20 элементов.Заполнить его случайными числами и найти количество элементов массива. значения которых больше заданного числа и кратны 5.

составьте программу для нахождения S круглого зеркала,используемого в телескопе, по формуле S=πR (в квадрате), радиус зеркала R=100,π=3,141595. Все

исходящие данные введите с клавиатуры. через программу паскаль 7.0 плиз очень надо



Вы находитесь на странице вопроса "СРОЧНО ПОЖАЛУЙСТА ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.