Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста с ИВТ: 1.Случайным образом генерируется N целых чисел в диапазоне от -5 до 5. Посчитать сколько среди них положительных,

5-9 класс

отрицательных, и не равных нуля. Задача решается через Turbo Pascal

Kurok2015 13 янв. 2015 г., 16:51:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
вероника09876
13 янв. 2015 г., 17:59:51 (9 лет назад)

#include <iostream>

 

using namespace std;

 

int main()

{

 int N;

 int i1=0,i2=0;

 cin>>N;

 for(int i=0;i<N;i++)

 {

  int a = rand()%11-5;

  if(a<0)

   i1++;

  if(a>0)

   i2++;

 }

 cout<<">0 - "<<i2<<endl<<"<0 - "<<i1<<endl<<"!=0 - "<<i1+i2<<endl;

 system("PAUSE");

}

 

P.S. Задачу можно решить не только через Turbo Pascal.

Ответить

Другие вопросы из категории

1. (53) Некоторый алфавит содержит 128 символов. Сообщение содержит 10 символов. Определите информационный объем сообщения. 2. (62) Мощность алфавита

равна 256 символов. Сколько килобайтов памяти потребуется, чтобы сохранить 320 страниц текста, содержащего в среднем 256 символов на каждой странице? 3. (61) Племя Пульти пользуется 64-символьным алфавитом. Свод основных законов племени хранится на 1024 глиняных табличках, на каждую из которых нанесено ровно 512 символов. Какой объем информации содержится на каждом носителе? Сколько информации заключено во всем своде законов? 4. (43) Жители планеты Альфа отправили на Землю сообщение, записанное с помощью всех символов используемого ими алфавита: МКЛКМНОНОПРОСТ! Определите информационный объем этого сообщения.

решить пример A+B+C*(-B)
1. Без каких из перечисленных ниже устройств работа компьютера невозможна: принтер, процессор, клавиатура, флэш-память, монитор, оперативная память,

устройство CD-ROM?
3. Какова разрядность процессоров у современных персональных компьютеров?
4. Запишите возможный объем следующих носителей информации, используя указанные в скобках варианты ответов (1,44 Мбайт, 700 Мбайт, 120 Гбайт, 512 Мбайт, 4,7 Гбайт):
а) CD-R;
б) DVD-R;
в) флэш-память;
г) дискета;
д) жесткий магнитный диск.

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

Помогите пожалуйста)

Составьте программу,которая заполняет массив a[1..8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.

Помогите пожалуйста)

1.Составьте программу ввода с клавиатуры элементов массива a[1..10] и вывода на экран элементов с четными значениями и четными индексами.
Пример ввода:4 5 6 3 9 8 4 10 7 2
2.Составьте программу,которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы,значения которых больше 5 и меньше 15.



Вы находитесь на странице вопроса "Помогите пожалуйста с ИВТ: 1.Случайным образом генерируется N целых чисел в диапазоне от -5 до 5. Посчитать сколько среди них положительных,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.