Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

вводится последовательность чисел , 0 - конец последовательности . вычислить сумму чисел после первого отрицательного

10-11 класс

Angelina771 08 нояб. 2016 г., 7:18:08 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikazamarina
08 нояб. 2016 г., 9:03:52 (7 лет назад)

Если на паскале 

program dds;

const n=10;
var a:array[1..n]of integer;
i,o,s,z:integer;
begin randomize;s:=0;z:=0;a[n]:=0;
a[n]:=0;for i:=1 to n-1 do a[i]:=random(10)-5;
for i:=1 to n do if (a[i]<0) and (z=0)
then begin z:=1; for o:=i+1 to n do
s:=s+a[o];end
;for i:=1 to n do write(a[i]:4);writeln;
write('symma=',s);

readln;
end.

Ответить

Другие вопросы из категории

Написать программу для Паскаль

Найдите самую низкую температуру за время наблюдения, если температура опускалась нижу 15 градусов, выведите да, иначе - нет. Программа получает на входе количество дней, а для каждого дня вводится температура.

как расставить в комнате 5 стульев?

Читайте также

Составить алгоритм решения задачи согласно своему варианту и написать программу на языке С++. В отчете предоставить блок-схемы функции :

Задание

Вводится последовательность целых чисел, 0 – конец последовательности.Для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – Да, 0 - НЕТ).

Составить алгоритм решения задачи согласно своему варианту и написать программу на языке С++. В отчете предоставить блок-схемы функции :

Задание

Вводится последовательность целых чисел, 0 – конец последовательности.Для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – Да, 0 - НЕТ).

1. В последовательности чисел подсчитать произведение чисел, кратных 3.

2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных.
3. В последовательности чисел определить предпоследнее отрицательное число. (При решении введите дополнительную переменную для хранения предпоследнего отрицательного числа).

33. Последовательность чисел

Вводится последовательность целых чисел, заканчивающаяся нулем. Преобразовывать последовательность следующим образом:

1) заменить отрицательные числа в последовательности на их модули и вывести получившуюся последовательность;

2) в полученной последовательности заменить четные числа на максимальное число последовательности, вывести результат;

3) в полученной последовательности вычесть из каждого члена последовательности 2, вывести результат;

4) в полученной последовательности заменить отрицательные на 0, вывести результат.



Пример.

Последовательность: 1 2 3 0

1) 1 2 3

2) 1 3 3

3) –1 1 1

4) 0 1 1

Построить последовательность чисел Фибоначчи: F=0,1,1,2,3,5,8,13,….n.

Числа Фибоначчи : последовательность, каждый следующий элемент которой равен сумме 2-х предыдущих., причем известно, что первый член последовательности f0=0, в второй f1 =1.



Вы находитесь на странице вопроса "вводится последовательность чисел , 0 - конец последовательности . вычислить сумму чисел после первого отрицательного", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.