Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных. Паскаль

5-9 класс

Indigo777 02 авг. 2014 г., 4:21:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Izelka2003
02 авг. 2014 г., 4:53:16 (9 лет назад)

program z8;
uses crt;
var a:array[1..259] of shortint;
i,k,n:byte;
s:integer;
begin
clrscr;
randomize;
write('Vvedi razmernost massiva=');
readln(n);
for i:=1 to n do begin
a[i]:=random(100--100+1)+-100;
write(a[i]:4);
if a[i]<0 then
s:=s+a[i];
if odd(a[i]) then
k:=k+1;
end;
writeln;
writeln('Сумма отрицательных элементов равна ',s);
writeln('Кол-во нечётных элементов равно ',k);
readkey
end.

Ответить

Другие вопросы из категории

Читайте также

Помогите, пожалуйста, написать программу, и составить блок-схему.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. Найти и вывести на экран номера двух элементов массива, наименее отличающихся друг от друга.

Дан массив из N элементов(12 элементов), заданный случайным образом от -10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N.

Вывести на экран часть массива входящих в диапазон, двух введенных чисел. Эти два числа будут индексами к тем числам, которые надо вывести.

Вводятся 4 числа. Вывести на экран максимальное

Вводятся три числа. Вывести на экран число с минимальной суммой цифр.

Помогите пожалуйста в Паскале

Задание1. Значение переменной Х ввести с клавиатуры. Переменной У присвоить значение 5. Вывести на экран информацию «знач.Х»+5=

«итог. сумма».

Задание 2.

Переменной Х присвоить значение 7. Переменной Р присвоить значение, равное квадрату Х. Вывести значения переменных Х и Р (через запятую). Значение Х увеличить на Х. Переменной Р присвоить значение, равное корню квадратному из Х. Вывести значения переменных Х и Р (через запятую).

DIKTANT 2

Задание 1.

Значение переменной Х присвоить в программе. При неотрицательном значении Х переменной У присвоить значение, равное корню квадратному из Х. В противном случае, переменной У присвоить значение, равное квадрату Х. Вывести на экран значение Х и значение У.

Задание 2.

Двум произвольным переменным присвоить произвольным образом соответственно 2 числа. Двум другим переменным присвоить значения, равные тангенсам двух предыдущих переменных. Вывести на экран значения всех переменных, а так же сумму значений двух последних переменных. помогите сделать пож



Вы находитесь на странице вопроса "Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных. Паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.