Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Pascal. Geany пожалуйста

5-9 класс

Найти сумму и произведение четных чисел от a до n (a<n)

нфаст 26 апр. 2013 г., 16:18:47 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jhfghj
26 апр. 2013 г., 17:37:24 (11 лет назад)

Program z;
Uses crt;
Var a,n,i,sum, pro:integer;
Begin
Sum:=0;
Pro:=1;
Writeln ('введите число a'); read (a);
Writeln('введите число n(>a)'); read (n);
For i:= a to n do
Begin
If odd(i) then
Begin
Sum:= sum+i;
Pro:= pro*i;
End;
End;
Writeln('sum=', sum);
Writeln('pro=', pro);
End.

+ 0 -
Hjng
26 апр. 2013 г., 18:10:59 (11 лет назад)

сори, ошибочка: не "if odd (i)...", а "if not odd(i)..."

Ответить

Другие вопросы из категории

Сколько раз выполнится тело цикла

for n:=3 to 6 do write( ' * ' ) ;?

как перевести 243 в десятой в шестнадцатеричную систему счисления ? 9 в десятой в шестнадцатеричную систему счисления.1101111 во второй в восьмеричную и

шестнадцатеричную систему счисления. (ЖЕЛАТЕЛЬНО ПОПОДРОБНЕЕ, С ОБЪЯСНЕНИЕМ!!!)

Всем доброго времени суток. Пожалуйста, помогите написать программу на Паскале, я вам буду очень благодарен за помощь.

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 8. Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести одно число – сумму чисел, оканчивающихся на 8.

Читайте также

Geany,пожалуйста

Вывести на экран строчку из 10 единиц. Затем в этой же программе вывести на экран 5 строчек по 10 единиц. (нужно повторять цикл for)

Написать программу Turpo pascal помогите пожалуйста что сможете!!! Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу

вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.

Определение факториала:

0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.

Другими словами n!- это произведение n натуральных чисел.



Вы находитесь на странице вопроса "Pascal. Geany пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.