Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Всем доброго времени суток. Пожалуйста, помогите написать программу на Паскале, я вам буду очень благодарен за помощь.

5-9 класс

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 8. Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести одно число – сумму чисел, оканчивающихся на 8.

32323232 07 марта 2017 г., 7:25:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Matmorozoff
07 марта 2017 г., 10:07:25 (7 лет назад)

type
  ta = -300..300;

var
  a: ta;
  i, s, n: integer;
  c: string;

begin
  writeln('Введите количество чисел');
  readln(n);
  if n>100 then begin
     writeln('Нельзя ввести более 100 чисел');
     exit
     end;
  s := 0;
  for i := 1 to n do
  begin
    read(a);
    Str(a, c);
    if c[length(c)] = '8' then
      s := s + a;
  end;
  if s=0 then
     writeln('Нет ни одного числа, оканчивающегося цифрой 8')
   else
     writeln('Сумма чисел ', s)
end.

Контрольный пример

Введите количество чисел
10
4
-5
8
21
28
-80
25
38
24
-45
Сумма чисел 74


Ответить

Читайте также

Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в

зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Ребят) Помогите с программой на Паскале, пожалуйстаа)

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)

Помогите написать программу на Паскале. Найти

a_{n} и S арифметической прогрессии через цикл for.



Вы находитесь на странице вопроса "Всем доброго времени суток. Пожалуйста, помогите написать программу на Паскале, я вам буду очень благодарен за помощь.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.