Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в

5-9 класс

зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"

ватапрмаи 29 апр. 2013 г., 21:33:13 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gaget
29 апр. 2013 г., 23:13:59 (11 лет назад)

uses crt;
var day:integer;
begin
writeln(day);
if (day > 0) and (day < 25) then
case day of

0:writeln('Good night!');;
1:writeln('Good night!');;
2:writeln('Good night!');;
3:writeln('Good night!');;
4:writeln('Good morning!');;

24:writeln('Good night!');
end.

 

дальше доделай сам

Ответить

Другие вопросы из категории

Помогите пожалуйста решить задачу в паскале.Надо программу составить..

для 2ух целых чисел надо определить,являются они четными или нет.Для проверки четности используем услование:остаток от деления на 2 четного числа равен 0

Читайте также

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

Ребят) Помогите с программой на Паскале, пожалуйстаа)

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)

Помогите сослать программу на Паскале.Поиск чисел в массиве. Program Example;

{Программа заполняет массив Rand случайными числами в диапазоне от 0 до 50,
вводит число Х, и вычисляет, сколько раз Х входит в массив Rand}

Var Rand: array[1..20] of integer;
I, X, NumberX : integer,
Begin
{Установка датчика случайных чисел}
​Randomize;
{Заполнение массива случайными числами и вывод их на экран}
​Writeln(‘Массив случайных чисел:’)
​For I:=1 to 10 do
​begin
​ Rand[I]:=random(50); Write(Rand[I]:4)
​End;
​Writeln;
{Ввод Х}
​Write(‘Введите Х:’)); Readln(X);
{Подсчет числа вхождений Х в массив}
​NumberX:=0;
​For I:=1 to 10 do
​​If Rand(I)=X then NumberX:=NumberX+1;
{Анализ и вывод результата}
​If NumberX=0
​Then​writeln(‘В массиве нет числа’,X)
​Else writeln(‘Число’,X,’в массиве присутствует’,NumberX,’раза’)
End.

написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то

поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после перестановки цифр. В противном случае, вывести выбранное ПК число



Вы находитесь на странице вопроса "Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.