Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ребят) Помогите с программой на Паскале, пожалуйстаа)

5-9 класс

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)

NKatya82 26 апр. 2013 г., 15:07:39 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KatrinPalienko
26 апр. 2013 г., 16:31:12 (11 лет назад)

Var i:integer;

Begin

For i:=10 to 99 do

Begin

if (i mod 3=0) or (i mod 5=0) then Writeln(i);

end;

readln;

end.

+ 0 -
Luybalwowa
26 апр. 2013 г., 18:04:53 (11 лет назад)

var i:integer;
begin
for i:=10 to 99 do
if (i mod 3=0) or (i mod 5=0) then write(' ',i);
end.

Ответить

Другие вопросы из категории

(Паскаль)2 Заполнить с клавиатуры массив из 10 элементов.

Если максимальный элемент находится в первой половине массива подсчитать сумму
четных элементов массива, в противном случае подсчитать сумму нечетных
элементов массива.

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Помогите сослать программу на Паскале.Поиск чисел в массиве. Program Example;

{Программа заполняет массив Rand случайными числами в диапазоне от 0 до 50,
вводит число Х, и вычисляет, сколько раз Х входит в массив Rand}

Var Rand: array[1..20] of integer;
I, X, NumberX : integer,
Begin
{Установка датчика случайных чисел}
​Randomize;
{Заполнение массива случайными числами и вывод их на экран}
​Writeln(‘Массив случайных чисел:’)
​For I:=1 to 10 do
​begin
​ Rand[I]:=random(50); Write(Rand[I]:4)
​End;
​Writeln;
{Ввод Х}
​Write(‘Введите Х:’)); Readln(X);
{Подсчет числа вхождений Х в массив}
​NumberX:=0;
​For I:=1 to 10 do
​​If Rand(I)=X then NumberX:=NumberX+1;
{Анализ и вывод результата}
​If NumberX=0
​Then​writeln(‘В массиве нет числа’,X)
​Else writeln(‘Число’,X,’в массиве присутствует’,NumberX,’раза’)
End.

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.



Вы находитесь на странице вопроса "Ребят) Помогите с программой на Паскале, пожалуйстаа)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.