Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Запросить стороны треугольника и определить,является ли он разносторонним,равносторонним или равнобедренным. Учесть: третья сторона не должна превышать

5-9 класс

сумму двух других,иначе треугольник не существует. Задача на тему "Программирование ветвлений на Паскале".

Илья130104 15 дек. 2014 г., 12:46:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Starladder
15 дек. 2014 г., 14:51:31 (9 лет назад)

var a,b,c: real;

begin

write('напишите 3 стороны треугольника(c>a+b)');

read(a,b,c);

if (a<>b) and (a<>c) and (b<>c) then write ('разносторонний');

if (a=b) and (a=c) and (b=c) then write ('равноносторонний');

if (a=b) and (b<>c) and (a<>c) then write ('равнобедренный');

end.

Ответить

Другие вопросы из категории

Коля при подключении Интернета выбрал тарифный план, который по-

зволяет загружать 100 Мбайт информации за 1 секунду. Придя домой, он
поставил на скачивание файл объёмом 204800 Кбайт. Через сколько секунд
будет скачан файл?

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "Запросить стороны треугольника и определить,является ли он разносторонним,равносторонним или равнобедренным. Учесть: третья сторона не должна превышать", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.