Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить алгоритм ,с помощью которого можно определить ,является ли треугольник с заданными сторонами a,b,c равносторонним ,равнобедренным или прямоуго

5-9 класс

льным

Pilotil97 08 окт. 2014 г., 19:19:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tone4ka1997
08 окт. 2014 г., 22:15:24 (9 лет назад)

var

  a, b, c : real;

begin

  read (a, b, c);

  if (a = b) and (b = c) then writeln ('Равносторонний')

  else if (a = b) or (a = c) or (b = c) then writeln ('Равнобедренный')

  else if (sqr (a) + sqr (b) = sqr (c)) or (sqr (b) + sqr (c) = sqr (a)) or (sqr (a) + sqr (c) = sqr (b))     then writeln ('Прямоугольный')

  else writeln ('No');

end.

  

Ответить

Другие вопросы из категории

И так друзья, я решаю чемпионат по информатике.. Вот 1 задание, пожалуйста, помогите решить, заранее очень благодарен:)

Вопрос:
В слове ЧЕМПИОНАТ поменяли местами буквы, стоящие на нечетных и следующих за ними четных позициях.Группы идущих подряд согласных букв какой длины можно найти в том, что случилось?
Варианты ответа:
А) 1
Б) 2
В) 3

Срочно!!! Помогите пожалуйста
Петя отправил через Skype Мише растровое изображение размером 256 на 256 пикселей . Скорость передачи составила 8 Мбит/с и заняло 1 минуту и 4 секунды

. Какое максимальное количество цветов в палитре изоброжения было использавано ?

А) 32

Б) 64

В) 128

Г) 256

Читайте также

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.



Вы находитесь на странице вопроса "составить алгоритм ,с помощью которого можно определить ,является ли треугольник с заданными сторонами a,b,c равносторонним ,равнобедренным или прямоуго", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.