Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

10-11 класс

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка

цвиол 05 июня 2013 г., 3:04:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
иришка1998
05 июня 2013 г., 4:22:30 (10 лет назад)


var a: array [1..100,1..100] of longint ;i, j ,d, n,m,k: longint;beginread(n,m);
for i:=1 to n do for j:= 1 to m doread(a[i,j]);
j:=0;
        for i:=1 to n do        begin        j:=j+1;        d:=0;                 while d<2 do                 if a[i,j]<0 then begin k:=k+1; d:= 3; end;        end;

if k>(m/2) then        begin        for i:= 1 to n do                 for j:= 1 to m do                 if a[i,j]<0 then a[i,j]:=a[i,j]*10 ;
        end
else
begin        for i:=1 to n do         for j:= 1 to m do         if a[i,j]<0 then a[i,j]:=a[i,j]*a[i,j] ;end;
for i:=1 to n dobegin for j:= 1 to m dowrite(a[i,j],' ');end;end.

Ответить

Другие вопросы из категории

плохо очень знаю С++ оч надо решить задачи

1)дан одномерный массив заполнит его так чтобы получилась геометрическая прогрессия где первый член равен 2, d=-3 и вывести в столбец.
2)вывести массив в строку и найти минимальный элемент массива.
3)отсортируйте его по возрастанию и вычислите произведение элементов массива.

Читайте также

Дана целочисленная прямоугольная матрица А размерности n*m. Переменной В присвоить значение, равное количеству строк

матрицы, содержащих хотя бы один нулевой элемент. (Помогите написать программы на с ++)

Написать программу для паскаля. Дана квадратная матрица

порядка n(n=5).
Если в данной матрице a нет отрицательных элементов,
то транспонировать её, иначе выдать сообщение.

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.



Вы находитесь на странице вопроса "Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.