Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить программу сумму трехзначных чисел на mod и div

5-9 класс

Drakon1230 27 сент. 2013 г., 15:35:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hoholovich6
27 сент. 2013 г., 16:06:41 (10 лет назад)

Насколько я понял нужно разбить трёхзначное число по разрядам и найти их сумму
var
 n,n1,n2,n3:integer;
begin
 readln(n);
 n1:=n div 100;
 n2:=(n div 10) mod 10;
 n3:=n mod 10;
 writeln(n1+n2+n3);
end.

Ответить

Другие вопросы из категории

Кулинар приготовил торт из трех коржей и положил его на зеленый поднос. Но оказалось, что посуда на столе красного цвета. Помогите кулинару

переложить все коржи на красный поднос, используя желтый поднос как вспомогательный. За один ход можно переложить только один корж, и маленький корж нельзя положить на большой.

Помогите с одномерными массивами!

Дан массив целых чисел.
а) все отрицательные элементы увеличьте на 10
б) выяснить, верно ли, что средних арифметических элементов больших 20, превышает 50.

Помогите 4 и 5 задания умаляю
а) Укажите,как организованы следующие вложенные папки.

Музыка Рисунки
Тексты Фильмы

∞по принадлежности
∞по назначению
∞по содержимому
∞по времени создания
б)
Программы по математике Программы по информатике
Программы по географии Игровые программы
∞по принадлежности
∞по назначению
∞по содержимому
∞по времени создания
в) Работы Коли Работы Пети
Работы Руслана Работы Маши
∞по принадлежности
∞по назначению
∞по содержимому
∞по времени создания
г) 2011 2012
2013 2014
∞по принадлежности
∞по назначению
∞по содержимому
∞по времени создания
Просьба: отвечайте на все вопросы,которые содержаться в задании! Не надо сокращать ответы!

Читайте также

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на

вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4. Пояснение: цикл while x<>0 do с условием if (x mod 6=0) and (x mod 10=4)

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal



Вы находитесь на странице вопроса "составить программу сумму трехзначных чисел на mod и div", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.