Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

создать программу в паскале: желательно побыстрее,а то утром уже на учебу ))))))

10-11 класс

Ivlevatatyana8026 04 июня 2014 г., 4:34:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анннннна
04 июня 2014 г., 6:08:33 (9 лет назад)

var x,y: real;

begin

  readln(x);

  if x<=0 then y:=exp(x);

  if (x>0) and (x<=1) then y:=0;

  if x>1 then y:=ln(x);

  writeln(y:0:4);

end.

+ 0 -
King20000
04 июня 2014 г., 6:46:07 (9 лет назад)

var y,x:real;
begin
write('Введите x = ');
readln(x);
if (x<=0) then y:=exp(x) else if x>1 then y:=ln(x) else y:=0;
writeln('y = ',y:0:2);
end.

Ответить

Другие вопросы из категории

Program z;

var
s:real;
i,x,n:integer;
begin
writeln('ввод x,n');
readln(x,n);
for i:=n to 1 do
s:=s*(((-1)*exp(i+1)*ln(1))/exp(i+ln(2*x+1)));
writeln('ответ s=',s);
end.

По какой причине S ,независимо то значений X и N, получается равным нулю?

Составить легкую программу!

Зеркально отразить последовательность в одномерном массиве.

Т.е. Задаем последовательность, вводим границы "зеркала" - х и у. И зеркально отражаем.
Пример:12345678910
х=5

у=8

Вывод:12348765910.
Очень буду блгодарна!

Читайте также

Написать программу в паскале, которая после введенного с клавиатуры числа(в диапазоне от 1 до 99), обозначающий денежную единицу, дописывал слово

"Копейка". Например ,5 копеек,41 копейка и тд.

Вот мои попытки создать программу:

Program Kopeika;
Var a:integer;
begin
Writeln('Vvedite chislo');
Readln(a);
Case a of
'1,21,31,41,51,61,71,81,91': a:='Kopeika ';
'2..4,22..24,32..34,42..44,52..54,62..64,72..74,82..84,92..94': a:='Kopeiki ';
'5..20,25..30,35..40,45..50,55..60,65..70,75..80,85..90,95..99': a:=' Kopeek';
end;
Readln;
end.



Вы находитесь на странице вопроса "создать программу в паскале: желательно побыстрее,а то утром уже на учебу ))))))", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.