Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить легкую программу!

10-11 класс

Зеркально отразить последовательность в одномерном массиве.

Т.е. Задаем последовательность, вводим границы "зеркала" - х и у. И зеркально отражаем.
Пример:12345678910
х=5

у=8

Вывод:12348765910.
Очень буду блгодарна!

David990 19 мая 2014 г., 5:58:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Нина2468
19 мая 2014 г., 7:38:42 (10 лет назад)

Вот, пингвинчик :3 Можно было и короче, переменных поменьше и циклов... Но раз задача именно такая, то лучше не сокращать, а то могут оценку снизить)

var a: array [1..10] of integer;
    i, x, y, xi, yi, t: integer;
begin
     for i := 1 to 10 do
         readln(a[i]);
     writeln('X, Y');
     readln(X, Y);
          
     for i := 1 to 10 do
     begin
         if (a[i] = X) then xi := i;
         if (a[i] = Y) then yi := i;
     end;
     t := a[xi];
     a[xi] := a[yi];
     a[yi] := t;

     for i := 1 to 10 do
         writeln('[', i, '] => ', a[i]);
end.

+ 0 -
Mundo1
19 мая 2014 г., 10:27:04 (10 лет назад)

var a: array [1..10] of integer;
    i, x, y, xi, yi, t: integer;
begin
     for i := 1 to 10 do
         readln(a[i]);
     writeln('X, Y');
     readln(X, Y);
          
     for i := 0 to abs(round(0.5*(x-y))) do
     begin
      

+ 0 -
Summer2012
19 мая 2014 г., 12:41:28 (10 лет назад)

Она правда не сложная, помогите пингвину :(

Ответить

Другие вопросы из категории

Срочно! Есть возможность заработать 50 баллов!!!!!!!!!!!!!!!!!

Составить таблицу истинности для выражения

Написать программу на VB согластно заданию. Даны итоги выборов в Думу в городе: по K округам известно число голосовавших за представителей M

партий, а также число не участвовавших в голосовании по каждому округу. Выборы в округе считаются состоявшимися, если в голосовании приняло участие не менее P % избирателей. Определить в каких округах выборы состоялись.

Читайте также

помогите пожалуйста! составить линейную программу, паскаль

первую или вторую задачу
вторая: троллейбус за время t прошёл пусть s
какую скорость v приобрёл он в конце пути и с каким ускорением a двигался, если начальная скорость движения равна .v0.(77)

составить линейную программу, которая печатает true, если точка

с координатами (х, у) принадлежит закрашенной области, и false — в
противном случае:



Вы находитесь на странице вопроса "Составить легкую программу!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.