Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

вопрос : составить программу которая определяет a) уместится ли круг в кводрате b) уместится ли квадрат в круге

10-11 класс

Няфуня 11 июля 2014 г., 13:43:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Дмитрийййй
11 июля 2014 г., 15:44:34 (9 лет назад)

Думаю так)

 

a)

uses crt;
var sKr,sKv,a,r:real;
const pi = 3.14;
begin
writeln('Write a (side of square)');
readln(a);
writeln('write radius of circle ' );
readln(r);
skr:=pi*sqr(r);
skv:=sqr(a);

if skr <skr then writeln('ok') else writeln('NO');
readln;
end.

 

b)

 

uses crt;
var sKr,sKv,a,r:real;
const pi = 3.14;
begin
writeln('Write a (side of square)');
readln(a);
writeln('write radius of circle ' );
readln(r);
skr:=pi*sqr(r);
skv:=sqr(a);

if skr > skr then writeln('ok') else writeln('NO');
readln;
end.

+ 0 -
Buba69
11 июля 2014 г., 16:15:05 (9 лет назад)

Program Kvadrat_v_krug;
var a,r:real;
begin
  write('Введите сторону квадрата а=');
  readln(a);
  write('Введите радиус круга r=');
  readln(r);
  if 2*r < a*sqrt(2) then writeln('Квадрат не поместится в круге')
  else writeln('Квадрат можно поместить в круг');
end.

Program Krug_v_kvadrat;
var a,r:real;
begin
  write('Введите сторону квадрата а=');
  readln(a);
  write('Введите радиус круга r=');
  readln(r);
  if a < r then writeln('Круг не поместится в квадрат')
  else writeln('Круг можно поместить в квадрат');
end.

Ответить

Другие вопросы из категории

8. Запишите имя файла, для которого

выполнились бы все перечисленные ниже условия:

В чем преимущество компьютерных информационных моделей перед теоретическими?

Вопрос из учебника информатики за 10 класс, автор Семакин, §13 "Компьютерное информационное моделирование"

Program z;

var
s:real;
i,x,n:integer;
begin
writeln('ввод x,n');
readln(x,n);
for i:=n to 1 do
s:=s*(((-1)*exp(i+1)*ln(1))/exp(i+ln(2*x+1)));
writeln('ответ s=',s);
end.

По какой причине S ,независимо то значений X и N, получается равным нулю?

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))



Вы находитесь на странице вопроса "вопрос : составить программу которая определяет a) уместится ли круг в кводрате b) уместится ли квадрат в круге", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.