Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Программа выполняется в Паскале! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, им

5-9 класс

еются ли в записи числа N нечетные цифры. Если имеются, то вывести True, если нет — вывести False. Помогите плииз.

Annabee 28 дек. 2013 г., 5:08:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sp0ke
28 дек. 2013 г., 8:04:11 (10 лет назад)

var n:integer;
Begin
    Read(n);
    while (n>0) do begin
        if(n mod 2 = 1) then begin
            writeln(true);
            exit;
        end;
        n := n div 10;
    end;

    writeln(false);
End.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА!!!

Пятиклассник Вовочка однажды в кино увидел такую сцену – несколько мошенников обыгрывали зевак в игру с монетками. На столе находилась 21 монетка и ведущий предлагал сыграть с ним по следующим правилам – нужно брать по очереди 1-2-3-4 монетку и кто берет последнюю, тот и проиграл. При этом ведущий благосклонно предлагал первым ходить игроку. Вовочка уже и не помнил про что был этот фильм, но вот игру запомнил и старается понять как это ведущий всегда выигрывает…Попробуйте и Вы понять, как правильно играть в эту игру и определить сможет ли ведущий выиграть у Вас, если Вы играете правильно при следующих количествах монеток на столе: 45, 53, 74, 113.В ответе укажите 4 слова с большой буквы Да или Нет. Да – если выиграет ведущий, Нет – если выиграете вы.

Помогите пожалуйста

1.Совокупность всех программ образует ... обеспечение компьютера.
2.Совокупность всех устройств образует ... обеспечение компьютера.
3.Совокупность текстовых,графических,звуковых и других файлов образуют ... ресурсы компьютера.

Читайте также

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

плз помогите.. составить программу на языке авс паскаль 1)напишите программу, которая считывает два целых числа a и b

и выводит наибольше значение из них. Числа - целые от 1 до 1000.

при решении задачи можно пользоваться только целочисленными арифметическими операциями +,-,*,//,%,=. нельзя пользоваться нелинейными конструкциями:ветвления, циклами, функциями вычисления модуля, извлечения квадратного корня., и условными функциями!!!!!!!

2) Дано целое число N. Выведите следующее за ним четное число. При решении задачи нельзя использовать условную инструкцию if и циклы!!

хотя бы формулу:) заранее спасибо)



Вы находитесь на странице вопроса "Программа выполняется в Паскале! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, им", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.